#11 Can't send mail (continue from 593307)

closed
Read Mail (122)
5
2005-04-01
2002-08-11
No

I tried to turn off sent items - only root is can send - I
can however save a draft as user.

One thing I noticed, at the end of the browser there is a
status line reading:

"klaus logged into Usermin 0.940 on server (Slackware
Linux 3.6)"

When I go into the Read Mail (:20000/mailbox) the
status line changes to:

"klaus logged into Usermin 0.940 on UNKNOWN
(Slackware Linux 3.6)"

This does not happen when I am root? I do not have
the /etc/generics file installed (and it is set to None in
prefs) nor do I have the PAM module installed as the
Prefs allows me just to use /etc/shadow

Is it some kind of authentication issue or?

Hope you can help

Klaus

Discussion

  • Jamie Cameron

    Jamie Cameron - 2002-08-12

    Logged In: YES
    user_id=129364

    For the sending mail problem, does it make any difference if
    you configure
    the module to send via an external SMTP server (or even
    localhost)
    instead of running the sendmail program?

    As for the UNKNOWN error, that is a very strange one .. Does
    it happen
    in any of the other modules? It should only occur if the
    'hostname'
    command cannot be run by users for some reason.

     
  • Klaus Lovgreen

    Klaus Lovgreen - 2002-08-12

    Logged In: YES
    user_id=592962

    I have not tried to configure the module? Where can I set
    localhost / SMTP in usermin? In the readmail module from
    webmin?

    I have webmin as well and there UNKNOWN never appears -
    only in Usermin. I have checked id UNKNOWN appears in
    the other modules and the answer is Yes! - All modules act
    the same - I can browse the categories like Applications etc,
    but once I enter a module the UNKNOWN appears.

    Any ideas how to fix this as it appears to be the problem. As
    root UNKNOWN does not show up and I can send mail
    perfectly well.

    Does it have to do with which group the user belongs to? I
    have set all users to 'users' and also tried to make them
    member of mail - even root - but same result..??

     
  • Jamie Cameron

    Jamie Cameron - 2002-08-13

    Logged In: YES
    user_id=129364

    You can configure how mail is sent by going into the Usermin
    Configuration
    module of Webmin, clicking on Usermin Module Configuration,
    selecting
    Read Mail and changing the 'Send mail via connection to' option.

    As for the hostname display problem, this could be caused by
    normal users not having permission to enter the usermin module
    directories. Did you change any of the permissions on
    /usr/local/usermin-0.940 (or wherever you installed it) ?
    All files must be world-readable and world-executable.

     
  • Klaus Lovgreen

    Klaus Lovgreen - 2002-08-13

    Logged In: YES
    user_id=592962

    I have had a look at the files directories (which I did not
    change)
    They are all 755 and owned by root belonging to the group
    bin - perhaps that is an issue?

    I tried to set it to localhost - same result - can't send
    message - write error

     
  • Jamie Cameron

    Jamie Cameron - 2002-08-13

    Logged In: YES
    user_id=129364

    Give this a try - install the latest development version of
    usermin from
    http://www.webmin.com/devel/
    and try sending mail again. The error message should be a
    bit more
    explanative of what is going wrong ..

     
  • Klaus Lovgreen

    Klaus Lovgreen - 2002-08-13

    Logged In: YES
    user_id=592962

    Hi again, I solved the mail sending problem - it as a
    permission setting - I fixed it by:

    chowm mail.mail /usr/sbin/sendmail
    chmod 6555 /usr/sbin/sendmail

    (in case someone else face this problem)

    As for the UNKNOWN - is that a permission promlem too do
    you think? it is owned by root.bin

    Thanks for your help
    klaus

     
  • Jamie Cameron

    Jamie Cameron - 2002-08-13

    Logged In: YES
    user_id=129364

    Odd - sendmail should generally be executable by all users
    by default.
    For the UNKNOWN problem, what happens if you go into the
    Command Shell module of usermin and type the command
    hostname ?

     
  • Klaus Lovgreen

    Klaus Lovgreen - 2002-08-14

    Logged In: YES
    user_id=592962

    I tried to go to the Command Shell module and when
    executing the command hostname I get "server" and now in
    the browser it shows server as well. Still in the Readmail
    module it shows UNKNOWN...??

     
  • Anonymous - 2005-04-01

    Logged In: YES
    user_id=288773

    Closed.
    Submitter did not respond for more than half a year.
    We believe this bug is closed in Usermin-Version 1.120 an above.
    If you feel this is an error please re-open the bug.

     
  • Anonymous - 2005-04-01
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks