Sorry Jamie it is actually a different error i think the last virtaulmin update i did a couple of days ago changed it still an error (see below) but it is deleting the user/group now which is better. sorry did not notice untill i went to manually delete the user.


Deleting home directory ..
.. done

.. Administration user failed! : Failed to query Postfix config command to get the current value of parameter home_mailbox: at ../web-lib-funcs.pl line 1360.

Deleting server details for test123456.com ..
.. done



Here is the output of a top running average load on my physical machine.

top - 00:17:52 up 445 days, 10:21,  3 users,  load average: 0.09, 0.17, 0.22
Tasks: 334 total,   1 running, 333 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.1%us,  0.2%sy,  0.0%ni, 98.3%id,  1.3%wa,  0.0%hi,  0.1%si,  0.0%st
Mem:   4091076k total,  3810704k used,   280372k free,    75624k buffers
Swap:  9767288k total,  1551480k used,  8215808k free,   482128k cached

Not Virtual anything, I am old school running my own hardware (dell power edge 1650) at a co-lo connected to fiber.  4G seemed like alot a couple of years back and ECC pricy too, but it is mostly being used however i seriously doubt it is causing this error!

So i stopped some processes and got top to look like this lots of free RAM tried deleting another virtual server and got THE SAME ERROR

top - 00:23:36 up 445 days, 10:27,  3 users,  load average: 0.33, 0.31, 0.27
Tasks: 255 total,   1 running, 254 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0%us,  0.1%sy,  0.0%ni, 99.9%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   4091076k total,  1110992k used,  2980084k free,    78888k buffers
Swap:  9767288k total,   109628k used,  9657660k free,   494644k cached

However there is no postconf installed on this server i do not really want/need virtualmin to deal with email unless it can interface with Zimbra/Postfix?

root@mx1:/home/askidfj/public_html# postconf
The program 'postconf' is currently not installed.  You can install it by typing:
apt-get install postfix
-bash: postconf: command not found



Is your system perhaps low on RAM? I've seen this failure when the postconf command cannot be run due to lack of free memory ..

This is even more likely on an OpenVZ virtual system, as they often provide only "burstable" RAM that is not guaranteed to be available and causes this type of command failure.

 - Jamie

On 25/Apr/2011 22:42 RYAN vAN GINNEKEN <king@computerking.ca> wrote ..

Hello all

This error is ruining my day, when i try to delete a user, not using Webmin for email as i have another GUI specifically for email.  This never used to happen, expect it has to do with some Webmin update done at some time however not sure which version of Webmin it started happening with. 

<snip>

Deleting home directory ..
.. done

.. Administration user failed! : Failed to query Postfix config command to get the current value of parameter home_mailbox: at ../web-lib-funcs.pl line 1340.

Deleting server details for test1234.com ..
.. done

<snip>

Also as the error states user and group do not get deleted

Thank you in advance


------------------------------------------------------------------------------
WhatsUp Gold - Download Free Network Management Software
The most intuitive, comprehensive, and cost-effective network
management toolset available today.  Delivers lowest initial
acquisition cost and overall TCO of any competing solution.
http://p.sf.net/sfu/whatsupgold-sd
-
Forwarded by the Webmin mailing list at webadmin-list@lists.sourceforge.net
To remove yourself from this list, go to
http://lists.sourceforge.net/lists/listinfo/webadmin-list