Hi Kris,

Actually I fixed the RPC errors after reading Jamie's RPC tutorial and gave firewall access to the range of base port plus 100.

THe BIND mod is supposed to glean the master address from the master server hostname within the BIND mod. But, I even tried hand entering the address (both physical and hostname) into each server to no avail.. I still get the following:

zone "dan.net" {
            type slave;
            masters {
            file "/var/named/slaves/dan.net.hosts";
zone "dan.com" {
            type slave;
            masters {
            file "/var/named/slaves/dan.com.hosts";
zone "dan.info" {
            type slave;
            masters {
            file "/var/named/slaves/dan.info.hosts";

So yes, it is calling the master local. named.conf also has this:

// a caching only nameserver config
controls {
            inet allow { localhost; } keys { rndckey; rndc-key; };

The only place to mess with that is in the control interface options module. I tried adding allowed IP addresses there, to no avail. I would have assumed assigning a cluster slave server would have modified that line in named.conf. if needed. I can hand enter the slave master address but that defeats the purpose of having the BIND mods linked.

I have to fix this by hand to get current clients back up but I need it fixed before I can put the billing client back online with account creation.

Date sent:                  Mon, 30 Apr 2007 10:53:02 -0400
From:                         Kris Deugau <kdeugau@vianet.ca>
Organization:             ViaNet Internet Solutions
To:                             Webmin users list <webadmin-list@lists.sourceforge.net>
Subject:                    Re: [webmin-l] BIND slave issue
Send reply to:            Webmin users list <webadmin-list@lists.sourceforge.net>

[ Double-click this line for list subscription options ]

danl@solvnet.net wrote:
> Sorry Kris,
> I'm just using the out of box BIND module in a VirtualminPro setup.
> In Webmin you can register other servers as webmin servers and
> then assign them as "cluster slave servers" in the BIND module.
> Essentially, I'm trying to see if there's a bug or I what I need to
> adjust to fix these RPC errors that I've been getting. So NS1 and
> NS2 have each other then as slave servers. For some reason NS2
> will receive the new domain during account creation but then gets
> an RPC invalid login error during the second access to NS2.

Hmm.  This sounds like a Webmin RPC error rather than a BIND
AXFR-related error;  as I noted before, a BIND server is either a master
or a slave for any given zone - it can't be both, and the errors you
showed from BIND indicate to me that one machine *is* trying to be both
master and slave for a zone.  Without seeing the named.conf and zone
files, I can't tell you anything more useful about what BIND is doing.

You *can* have a pair of servers with one machine acting as master for
some zones, and the other acting as master for the rest, but that's not
very common and you need a tool like Webmin to keep track of what's
where.  <g>


This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
Forwarded by the Webmin mailing list at webadmin- list@lists.sourceforge.net
To remove yourself from this list, go to
Domains by SolvNet

Be a domain reseller and make cash

Domain name registration and hosting solutions.