Help save net neutrality! Learn more.
Close

Bind8 module broke after Webmin 1.590 upgrade

Webmin
2012-07-16
2013-05-22
  • Bruce Friend

    Bruce Friend - 2012-07-16

    The BIND8 module was working on my CentOS 6.2 64bit serverand Webmin 1.580.  I upgraded to Webmin 1.590 and it no longer see's my configuration.  I tried shutting off SELinux  with no success.  I'm running chrooted at /var/named/chroot.  Even though I have the chroot directory set and select configuration file is under chroot, the module does not read the configuration file unless I put the full path including the chroot directory in the system configuration section.  It then shows me the zones, but they are all empty and I can not get the module to display them at all.

    Something changed as it worked before and does not now.  I have two systems that are like this.

     
  • John Adams

    John Adams - 2012-07-17

    Your lucky, I have never been able to make Bind work with Centos 6.x. It always used to.
    I understand that we have to stop it using a chroot and maybe change some paths, but this situation defeats me,
    and as most of the software I use needs bind and soon will not be able to run with centos5 I am in a tight spot.

    Sorry I can not help

     
  • d elleray

    d elleray - 2012-07-17

    hi

    as far as i and probably 90+% of the community you ought to use bind in chroot mode.

    it really is a piece of cake just use WEBMIN :-) or apt/ rpm/vyum to install it, tweak it and no more exploits..

    d.

     
  • John Adams

    John Adams - 2012-07-18

    Hi

    This detail from the chrisblackwell post in virtualmin issue list solved my issue:-

    "i've had issues with virtualmin, named & centos 6 but i do have it working. heres my checklist i now run through for a fresh install, some of it might help you get things working

        firstly get rid of bind-chroot yum -y remove bind-chroot
        edit /etc/sysconfig/named and remove/comment out any lines that look like ROOTDIR="/var/named/chroot"
        fix the owner of /etc/named.conf with chown named:named /etc/named.conf
        In Webmin go to Servers > Bind DNS Server > Module Config and check the following configs

    BIND DNS Paths

        Chroot directory to run BIND under: none
        Is named.conf under chroot directory?: no

    Zone file options

        Directory for master zone files: /var/named
        Directory for slave/stub zone files: /var/named/slaves
        Owner for zone files (user:group): named:named

    Restart named and you should be good to go"

    This I think means we are working in a non chrooted environment, why would Red hat stop using the chrooted environment?

    John

     
  • iwireless

    iwireless - 2012-07-25

    The problem seems to be the 1.590 upgrade.  When you do Bind in Chroot, there is a second named.conf file setup in the Chroot directory.  When changes are made in the Webmin Bind module, it should be changing both the Chroot and Root copies of the named.conf files (as the same).  But that is not happening, and Bind continues to use the Chroot conf file, and Webmin is only changing the Root conf file. Changing the Named.conf file location in the Bind Module conf does not seem to do anything.  The Chroot conf file still does not get updated.

    Please note that there were 2 changes in the Changelog from 1.580 to 1.590 for the Bind module. One of these caused the problem.

     

Log in to post a comment.