Jose Hernandez - 2017-01-04

I'm getting a signature verification error when trying to do an 'apt update' on my box in order to install the latest webming version. Here's the output on my server:

inuxadmin@ubuntu2:~$ sudo apt update
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease              
Ign:3 http://download.webmin.com/download/repository sarge InRelease    
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease      
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease    
Get:6 http://download.webmin.com/download/repository sarge Release [14.0 kB]
Get:7 http://download.webmin.com/download/repository sarge Release.gpg [173 B]
Err:7 http://download.webmin.com/download/repository sarge Release.gpg
  The following signatures were invalid: BADSIG D97A3AE911F63C51 Jamie Cameron <jcameron@webmin.com>
Fetched 14.2 kB in 0s (32.1 kB/s)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
8 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.webmin.com/download/repository sarge Release: The following signatures were invalid: BADSIG D97A3AE911F63C51 Jamie Cameron <jcameron@webmin.com>
W: Failed to fetch http://download.webmin.com/download/repository/dists/sarge/Release.gpg  The following signatures were invalid: BADSIG D97A3AE911F63C51 Jamie Cameron <jcameron@webmin.com>
W: Some index files failed to download. They have been ignored, or old ones used instead.

Was the gpg key for the repo updated recently? I setup the repo per the instructions at http://www.webmin.com/deb.html over a year ago and this is the first time I've seen this happen.