howto request: 403 Errors in new alias - (steps taken included)

Webmin
Scott B
2017-01-09
2017-01-09
  • Scott B

    Scott B - 2017-01-09

    Hi,
    I have a mount point that was previously only used for FTP access but we are impementing a new system that needs to access this directory via http to play the files directly within browsers. I just learned of this today and need to do it before 5:30 my time tomorrow AM :(

    FYI SELinux is NOT enabled.

    The mount point is:

    /home/virtualserver/recordings
    

    I've set up a Document Directory Alias for virtualserver:80

    /recordings to /home/virtualserver/recordings
    

    and I can use a browser to FTP to:

    ftp://ipaddress/recordings
    

    But when I try to:

    http://ipaddress/recordings 
    

    In httpd.conf I've added:

    <Directory "/home/virtualserver">
        AllowOverride NONE
        Require all granted
    </Directory>
    
    <Directory "/home/virtualserver/recordings">
        AllowOverride NONE
        Require all granted
    </Directory>
    

    I have also performed a:

    find . type -d -exec chmod 755 {} +
    

    Any ideas?

     
  • Scott B

    Scott B - 2017-01-09

    RESOLVED: Added:

    Options Indexes FollowSymLinks
    

    in my httpd.conf filw as in the following:

    <Directory "/home/virtualserver">
        AllowOverride NONE
        Require all granted
        Options Indexes FollowSymLinks
    </Directory>
    
    <Directory "/home/virtualserver/recordings">
        AllowOverride NONE
        Require all granted
        Options Indexes FollowSymLinks
    </Directory>
    
     
    Last edit: Scott B 2017-01-09

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks