I am following instructions on how to install on a Buffalo NAS with Linux Version 2.6.12.6-arm1. I can download webadmin but when I execute the next instruction
apt-get install libnet-ssleay-perl  openssl libauthen-pam-perl libpam-runtime libio-pty-perl libmd5-perl apt-show-versions
I get a lot of error messages along the lines of

Package libnet-ssleay-perl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
W: Couldn't stat source package list http://mirrors.kernel.org etch/main Packages (/var/lib/apt/lists/mirrors.kernel.org_debian_dists_etch_main_binary-arm_Packages) - stat (2 No such file or directory)
.

and I cannot proceed any further.
As you probably have guessed I'm not a proficient Unix user but can follow instructions pretty well.
Are the instructions out of date?
Any help would be greatly appreciated.