Help needed

Webmin
roger
2007-05-11
2013-05-21
  • roger

    roger - 2007-05-11

    Hi,

    I am new to this forum, can someone help on Webmin running on Apache?  I am following the instruction and installed Webmin.  Somehow, i dont have this file, "AuthUserFile /etc/webmin/htusers", so when i try to access Webmin @ ip:10000, I have constantly been asked for username and password.  Just can not get in.

    roger

     
    • PsyMan

      PsyMan - 2007-05-11

      Hi Roger,

      Webmin does not run "on apache" it is a standalone webservlet (if thats the right word) but anyway, initially to log in to webmin you will need your system root login and password, I then recommend setting up a user with only the modules you require which will make it all a little easier.

       
      • PsyMan

        PsyMan - 2007-05-11

        No, if you can already get as far as the webmin login screen on IP:10000 and its asking you for a username and password then you just enter your system root details. eg. login:root password:mypassword. If you are running it on ubuntu you may have to enable root user first (google how to do that as I am unsure)

         
    • roger

      roger - 2007-05-11

      Ok, so you mean I must run it from Server and create user for the first time, then I can use it over internet, right?

       
    • roger

      roger - 2007-05-11

      I am running it on Red Hat Enterprise. I can not get in when i tried to use username root or admin. login screen just keep coming back.

       
      • PsyMan

        PsyMan - 2007-05-11

        In that case I am not sure how to help, I have always used the command line rpm -U webmin-1.340-1.noarch.rpm and let it install, once the message telling you that you can log in using the root user it's always worked. try installing again using that method (if you did not the first time) it will automatically upgrade your existing installation. Good Luck

         
    • roger

      roger - 2007-05-11

      I did reinstall it, according to Webmin website, "Inside the <Directory> section. The file /etc/webmin/htusers must contains users who match up with those in /etc/webmin/webmin.acl.".  Because I dont have this htuser file, so I think that's where the problem is.  Anyway, Thanks!
      roger

       
    • Rodrigo

      Rodrigo - 2007-05-14

      have you tried to use root or admin without a password?

      i´ve seen cases where webmin didnt have a password set for the user, just the user name

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks