apt-get install hangs

Webmin
Geoff Lane
2016-01-14
2016-12-25
  • Geoff Lane

    Geoff Lane - 2016-01-14

    Folks,

    Have webmin running successfully on a couple of machines, R-pi running debian and a Laptop running Ubuntu.

    Having problems installing webmin onto a Raspberry Pi runnung Ubuntu Mate; it just hangs at unpacking webmin.

    Tried using gdebi from GUI, tried apt-get install and dpkg, all hang at the same place.

    Now apt-get upgrade says I must install webmin to correct problems but it will not install, I cannot remove it as it says I must first reinstall it.

    It is now preventing me from installing other items as the update tells me I must reinstall to correct problems.

    Any clues folks would be greatly appreciated, either to install or remove the part installation.

    Geffers

     
  • Elliot Huffman

    Elliot Huffman - 2016-02-22

    +1
    apt-get and dpkg -i both do not work.

    I have sueccessfully installed this awesome piece of software in the past but I am now unable to do so.

    I can confirm that this is happening on Ubuntu Server 14.04.4 x64 and Ubuntu Server 15.04 x64.

    The install is taking place in a VM, Oracle VBox. Disk activity is rampent although nothing appears to be happening.

    Thanks!

     
  • Elliot Huffman

    Elliot Huffman - 2016-02-23

    I just let it run for more than an hour and it completed successfully. I am guessing that the system was going slow.

    The VM has 4GB of RAM and 100% execution cap with 6 cores...

    I do not see why slow processing might be the cause.

    The system itself has 32GB of RAM.

     
  • Simon Carr

    Simon Carr - 2016-05-13

    I am also getting the same problem on a dedicated server with nothing else running. I will just have to hope that after an hour it completes the install

     
  • Jeff Howard

    Jeff Howard - 2016-11-24

    Just keep running dpkg. Yes it takes forever and I've no idea why. It never used to do and I've used webmin for years, but after a bit of patience it sees to have installed correctly. If I run into further problems I'll post back here.

     
  • Simon Carr

    Simon Carr - 2016-12-25

    Could it have anything to do with RAID rebuilding?

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks