I cannot make vhosts to work

Webmin
dinko
2013-08-27
2013-10-29
  • dinko

    dinko - 2013-08-27

    I am successfully using WebMin to a ubuntu server I have, but I cannot make vhosts to work in a new CentOS server. If I have only the default server installed in /var/www/html when I try to see my server using the IP address, I see the /var/www/html/index.html (that's correct). When I create a new vhost, although I setup directory and servername, the whole server (even with ip address) looks to this folder. I tried to find what it is but I cant. I noticed that the option " New file under virtual servers directory" is missing from the add new vhost form. Any idea?

     
  • gandolf

    gandolf - 2013-10-29

    this is not a webmin question but
    centos paths differently than say, debian, maybe ububtu
    you have to include the vhsots file - if you have one - at the bottom of the httpd.conf file ie.. Include /etc/httpd/conf/vhosts/Vhosts.conf
    then in vhost.conf
    NameVirtualHost ###.###.###.###:80
    <VirtualHost your="" server="" ip:80="">
    ...etc...
    </VirtualHost>
    and so on

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks