Change php settings to a specific site doesn't effect phpinfo

Webmin
Dani
2013-09-19
2013-10-29
  • Dani

    Dani - 2013-09-19

    I have a site under virtualmin. I run phpinfo and get the php configuration. trying to change display_errors on on

    log into webmin --> server --> apache webserver --> php Add configuration flag display_errors and set it to on and save. nothing happens. restarted httpd, nothing happens. it stays off.

    try to change through edit directives and add php_flag displau_errors on

    nothing happened again:
    display_errors Off Off
    display_startup_errors Off Off

    How do I change php settings for a specific virtual server (site) on my server ?

    thanks

     
    Last edit: Dani 2013-09-19
  • Mks Akula

    Mks Akula - 2013-09-19

    Hi,

    Try to change php settings in /home/your_domain/etc/php.ini (it's a link to php5/php.ini in the same folder). After save restart apache /etc/init.d/apache2 restart

     
  • Dani

    Dani - 2013-09-19

    this will change php settings to all sites.
    I want to change the settings only to my site.
    I used to run my own server with plesk and I used a add my local changes to vhost.conf

    Is there something similar here ?

     
  • Mks Akula

    Mks Akula - 2013-09-20

    Yes, you can use: webmin -> servers -> apache webserver -> select your site -> PHP and here you will use:
    PHP Configuration Valuess
    display_errors On

    You will notice in /etc/apache2/sites-available/your_site.conf

    php_value display_errors On

     
  • gandolf

    gandolf - 2013-10-29

    i advise that you leave errors off globally and turn them on individually at the script.
    <?php
    ini_set('error_reporting', E_ALL); // for log
    ini_set('display_errors', 1); // for show

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks