CGI problem

Webmin
Anonymous
2012-07-17
2013-05-22
  • Anonymous - 2012-07-17

    Hi guys, I have a problem with my current dedicated server. I installed and configured everything with webmin. Now I am faced with a problem that I can not fix. This is the CGI configuration, I have done so.

    <VirtualHost 204.145.65.12:80>
    DocumentRoot /home/***/www/***
    ServerName ***
    ServerAdmin webmaster@localhost
    SuexecUserGroup www-data www-data 
    Redirect /webmail http://webmail.***
    <Directory />
        Options None
    </Directory>
    Alias /cgi-bin/ "/home/***/www/***/cgi-bin/"
    #Alias /cgi-bin/ "/usr/lib/cgi-bin/"
    #<Directory /usr/lib/cgi-bin/>
    <Directory "/cgi-bin/">
     AllowOverride Options
                    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                    AddHandler cgi-script .cgi .pl
                    Order allow,deny
                    Allow from all
    </Directory>
    <Directory /var/www/>
             Options All
             AllowOverride All
             Order allow,deny
             allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    <Directory "/home/***/www/***/">
    AllowOverride All
    allow from all
    Options +Indexes +ExecCGI
    </Directory>
    </VirtualHost>
    

    That said the script is wrong is me back

     
  • Anonymous - 2012-07-17

    I forgot to tell you that returns the source code. That is:

    #!/usr/bin/perl
            print "Content-type: text/html\r\n\r\n";
            print "Hello, World.";

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks