SQUID Initialize Cache Fail

Webmin
Jim Layton
2017-01-01
1 day ago
  • Jim Layton

    Jim Layton - 2017-01-01

    Hi All,

    Latest Webmin and SQUID on Linuxlite whihc I believe is Debian9. Install seems to go fine but fails to enable cache with-
    FATAL: Bungled /etc/squid3/squid.conf line.....

    I tried uncommenting the suggested line-

    cache_dir ufs /var/spool/squid3 100 16 256

    This does not work

    Tried the suggestion here-
    https://sourceforge.net/p/webadmin/bugs/4523/

    This does not work.

    It is also not a permission error. Actually it looks like it might be a long standing Webmin bug. One thing I noticed is several variables including "..." in the conf file. It looks like the conf file itself may be bad or is getting rewriten somehow. Also of not is no SQUID3 folders anywhere to be found which seem to get referenced in the cache config in Webmin.

    I'm at a loss. This should not be that difficult. I feel like I'm missing something here. SQUID can run without any cache or so I'm told.

     
  • Jim Layton

    Jim Layton - 2017-01-02

    Exact error after uncommenting suggested line-

    Initializing the Squid cache with the command squid3 -f /etc/squid/squid.conf -z ..

    FATAL: Bungled /etc/squid/squid.conf line 3410: cache_dir rock /hdd1 ... min-size=100000
    Squid Cache (Version 3.5.12): Terminated abnormally.
    CPU Usage: 0.008 seconds = 0.004 user + 0.004 sys
    Maximum Resident Size: 155872 KB
    Page faults with physical i/o: 0

    Suspect lines of the conf-

    cache_dir rock /hdd1 ... min-size=100000
    cache_dir rock /ssd1 ... max-size=99999
    cache_dir rock /hdd2 ... min-size=100000
    cache_dir rock /ssd2 ... max-size=99999
    cache_dir rock /hdd3 ... min-size=100000
    cache_dir rock /ssd3 ... max-size=99999

    This is how they are actually written. The three dots included.

     
  • Jim Layton

    Jim Layton - 2017-01-02

    I am away from my office but will tomorrow. I also could not find a default config file anywhere in the wild.

    I eventually got this to work by manually adding the values "100 16 256" as seen below-

    cache_dir rock /hdd1 ... min-size=100000
    Becomes
    cache_dir rock /hdd1 100 16 256
    And so on for each reference

    After this the cache directories will build but SQUID is unable to write to the log file directory and throws another error. I then changed the user in Webmin to an administrator account and it finishes.

    Squid however still fails to start after all this. When you click on the "Start SQUID" button it executes a SQUID3 service which does not exist. Apparently at one point it was called SQUID3 or perhaps some distros create SQUID3 folders but either way it fails to run.. I'm not sure if this is a SQUID problem or a Webmin problem or a Debian problem.

    I then installed SQUID for Windows on one of our 2012r2 servers and it runs perfectly out of the box. Mind you I'm not blaming this on Webmin but SQUID is ridiculously complicated to get running on Linux.

     
    Last edit: Jim Layton 2017-01-02
  • Elizabeth

    Elizabeth - 1 day ago

    I just tried to install Squid through Webmin and ran into the exact same problem.

    I made a little more progress by going to "Module Config" and removing the number 3 from all references. This allows the Start Squid and Stop Squid buttons to work correctly.

    I did some research on the cache_dir rock lines. Apparently the default config is completely broken. I tried to remove all of the rock lines since it already has UFS cache. However, every time I hit initialize cache it re-creats the rock lines. Making further progress impossible

    At this point I'm giving up on the idea of running Squid through Webmin because even if I manually adjust the config file Webmin keeps overwriting it every time.

    I am running Webmin 1.831 and Squid 3.5.12 and Ubuntu Server 16.10.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks