Webmin non-responsive

Adam Frame
  • Adam Frame

    Adam Frame - 2012-08-18

    Good morning,

    I control various dedicated servers using Webmin/Virtualmin for ease of use.

    Last week two of these servers (which are on the same hosting provider) refused to allow access to my Webmin control panels. I get a time out every time I try to access.

    I have changed the Webmin ports (multiple times) and stopped the firewall, but I still get no response.

    netstat -an | grep :10000 shows:

    tcp        0      0     *                   LISTEN      
    tcp        0    810 <server IP>:10000           <my IP>:50905          ESTABLISHED 
    udp        0      0     *

    so it looks like it's listening fine and I am establishing connection. But I'm not getting anything whatsoever in my browser, just a timeout.

    I have tried accessing the localhost via lynx and it works fine so webmin isn't dying or anything.

    I haven't a clue where to look for a solution. Any help whatsoever would be much appreciated. TIA.


  • Roger

    Roger - 2012-08-19

    My Webmin stopped working recently.  I discovered that, somehow, port 10000 was no longer listed in my firewall's configuration file.  I added 10000 to the "TCP_IN" line in the config file and Webmin is working again.

    • Roger
  • Roger

    Roger - 2012-08-19

    … Oh, I also restarted the firewall after changing the config file.

    • Roger

Log in to post a comment.