File manager ACL button dissappeared?

  • D Stevenson

    D Stevenson - 2014-05-21

    I am hoping that this may have happened to someone else already...

    I was working in the Webmin File manager module setting permissions and creating ACL's for some shared folders and everything was working great. Then I logged out for a minute and when I logged back in the ACL button was gone from file manager. I tried uninstalling and reinstalling Webmin and also tried removing and reinstalling the File manager module and still cannot get the ACL button to show on the toolbar. I also cleared the java cache. Any suggestions would be greatly appreciated since I've already spent hours creating users and copying folders and files from our old Novell server. I know I can setup ACLs from the CLI but I would really prefer to work in Webmin's File Manager.

    Last edit: D Stevenson 2014-05-21
  • D Stevenson

    D Stevenson - 2014-05-22

    In case anyone is interested :-)

    After thinking about what changes I had made to the system before the button disappeared I remembered that I had edited the /etc/fstab file to enable acl support. I checked the file and found that I had put the acl option in the wrong place which made Webmins file manager think my file system did not support acl's and therefore did not display the button.

    Here is the relevant section of fstab I had edited before the button disappeared:

    UUID=xxxxx / ext4,acl errors=remount-ro 0 1

    and here is what it looks like after I corrected it:

    UUID=xxxxx / ext4 errors=remount-ro,acl 0 1

    Last edit: D Stevenson 2014-05-22

Log in to post a comment.