Version 1.330-1 rpm is broken

Webmin
Mark Wolf
2007-03-27
2013-05-21
  • Mark Wolf

    Mark Wolf - 2007-03-27

    The rpm for version 1.330-1 is broken. I appears to install correctly but it does not install the /etc files. I tried to install using rpmbuild on the spec file and it reported and error about copyright: freeware. I removed the line and it then complained about the need for a license data. I replace the line Copyright: freeware with License: GPL. I then rebuilt the rpm using the modified spec file and every thing install correctly.

    If you had a previous version installed this problem is masked because the /etc files are there from the earlier version and webmin will start. This issue arose when I used the rpm to do a fresh install on a new server.

    Mark

     
    • Tom Bradford

      Tom Bradford - 2007-03-30

      This might be why my installation of v1-330-1.noarch.rpm doesn't seem to work.  Or might not.

      I can't log-on to the server using localhost:10000 and when I tried to follow the instructions about getting through firewall couldn't find the specified /etc/sysconfig/ iptables file, just an iptables.config file.

      Could someone provide an idiot's guide to rectifying this, please.

       
      • d elleray

        d elleray - 2007-03-31

        try just stopping iptables (if that is the firewall running)

        service iptables stop

        and then get into webmin

        prove it is running first by

        service webmin stop
        service webmin start

        d.

         
    • Tom Bradford

      Tom Bradford - 2007-03-31

      Um, if I try: 'service iptables stop'I get 'iptables is not a valid service name'.

      If I try 'service webmin stop' I get 'webmin is not a valid service name'.

      If I try 'service webmin start' I get 'webmin is not a valid service name'.

       
      • d elleray

        d elleray - 2007-03-31

        ok

        you didn't say what os....

        try /etc/init.d/webmin status

        try /etc/init.d/iptables status
        then /etc/init.d/iptables stop

        d.

         
    • Tom Bradford

      Tom Bradford - 2007-03-31

      >>>you didn't say what os....

      CentOS 4.3

      >>>try /etc/init.d/webmin status

      = webmin (pid 7110) is running

      >>>try /etc/init.d/iptables status

      = firewall is stopped

      >>>try /etc/init.d/iptables stop

      =flushing firewall rules    [OK]
      setting chains to policy ACCEPT:
          mangle   nat  filter    [OK]
      Unloading iptables modules [OK]

      Trying http://10.10.0.10:10000 gets

      Error - Bad Request
      This web server is running in SSL mode. Try the URL https://elaine.totaranui:10000/ instead.

      Trying the URL gets me an IE cannot connect message.

      Now the confession/s:-

      1.  I'm not familiar with Linux but for my sins have taken on the admin of a non-profit community-owned wireless network in New Zealand to bring a half-way decent Internet connection to a remote and rural location.

      2.  I installed webmin onto CentOS + SME v7 on what is intended to become our server.  I assume SME is also running and have no idea how to stop it.  Dunno if that's relevant but elaine.totaranui is the machine name/domain I gave SME.

      Sorry if I wasted your time.

       
    • Tom Bradford

      Tom Bradford - 2007-03-31

      OK, acting on instinct I tried https://10.10.0.10:10000 and got in to webmin. 

      Looks easier for a newbie like me to cope with, so how do I disable SME as presumably I don't need that running at the same time?

      Thanks

       
    • Tom Bradford

      Tom Bradford - 2007-04-01

      Now it's stopped working.  init.d tells me that webmin is running and the firewall is stopped.  I can log-on to SME at 10.10.0.10 but https://10.10.0.10:10000 simply times out.

       

Log in to post a comment.