Problems setting up a share in samba

Webmin
flycast1
2012-05-31
2013-05-22
  • flycast1

    flycast1 - 2012-05-31

    I just set up an Ubuntu server with webmin. Looks good so far.
    I am having issues getting Samba to work. I have been able to set up shares but cannot connect with a windows 7 machine. I get:

    You do not have permission to access the //server/folder

    So far I have tried the following:
    Set up a new share and allow the folder to be created. Open the share up so that guests can have access and can write.
    I can browse the share but cannot copy a file from windows.

    Set up a share on an existing folder.
    When I do this I cannot log on to the server.

    What could be wrong. By the way…I am restarting samba after making changes and saving.

     
  • Anonymous - 2012-06-25

    Have you found a solution to your issue? I am having the same type of problem. I have set up samba on my CENTOS box, and am trying to access folders and files from a windows xp machine. I can see the links to the centos box from my windows machine but I get an error that says access denied. I set up all permissions for read and write and still not able to access.

    Let me know if you have found a solution that you would like to share.

    Thanks

    Todd

     
  • Manpose

    Manpose - 2012-06-28

    You will have to perform a chown, chgrp or chmod the folder. If you want to  access from a group of users add a user account then chown to that user.  Then chmod the folder permissions to  660.  This will give every one in the group and the user read write privileges.  The 0 at the end gives everyone else no privileges.  If you want anyone to access it you put a 6 in place of the 0.  If you need help on octal privileges just google it.  Hope this helps.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks