Unable to install on Ubuntu server

  • Loenlin

    Loenlin - 2012-04-24

    I´m using Webmin on my Ubuntu 10.04 server for quite some time.
    Now I want to make a new server, but I can´t  install webmin anymore.
    I tried to install Webmin on a Ubuntu 11.10 server and on Ubuntu 12.04 beta2 server (both on the new server and on my desktop as virtual server with Virtualbox).

    When I use the APT repository or install de .deb file with gpkg I get the following error:

    /var/lib/dpkg/info/webmin.postinst: 59: cannot create /etc/webmin/uninstall.sh: Directory nonexistent

    chmod: cannot acces  ‘/etc/webmin/uninstall.sh’: File or Directory nonexistent
    grep: /etc/webmin/miniserv.conf: File or Directory nonexistent

    When I use the TAR.GZ file, I get this error:

    ERROR: The Webmin install script must be run as root

    It looks as if I´m not logged in as root, however I use a ssh connection as root (ssh root@192.etc.)

    Anyone got an idea whats wrong?

  • John M. Rasor

    John M. Rasor - 2012-07-24

    I'm getting the same thing on Ubuntu Server 12.04: "Directory nonexistent" for directories that do exist. Installed as root.

    At least, using the TAR.GZ file, you might try sudo to run the script as root.

  • John M. Rasor

    John M. Rasor - 2012-07-24

    dpkg -i webmin_1.580_all.deb worked perfectly on Ubuntu Server 10.04.

  • John M. Rasor

    John M. Rasor - 2012-07-24

    I just now installed webmin_1.580_all.deb on Linux Mint 13 Mate. No problems. Uninstalled, installed 1.590: no error messages, no webmin. Uninstalled, installed 1.580: no problems.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks