SSH not working :(

Webmin
Richard W
2006-10-08
2013-05-21
  • Richard W

    Richard W - 2006-10-08

    I have upgraded to 1.29 and then 1.3. With each of these, when I try to use SSH remotely, it fails. If I am on the same physical network, everything works fine. Remotely, everything else, apart from Command Shell, works fine.

    When I run SSH, I get the login miniscreen. When I enter the username and password, the miniscreen disappears and focus is passed to the black SSH screen, which displays "online" in the bottom right. However, it won't let me write.

    My Java console displays:
    Applet: overriding value of Terminal.fontSize with 12
    Applet: overriding value of Socket.host with linuxweb1.garibaldi.notts.sch.uk
    Applet: overriding value of Terminal.resize with screen
    ** The Java(tm) Telnet Application
    ** Version 2.5 for Java 2
    ** Copyright (c) 1996-2003 Matthias L. Jugel, Marcus Meissner
    ** Build: 20031210-1040
    jta: loading plugin 'Status'
    jta: loading plugin 'Socket'
    jta: loading plugin 'SSH'
    jta: loading plugin 'Terminal'
    colorSet: /de/mud/terminal/colorSet.conf
    Socket: can't connect: java.net.ConnectException: Connection timed out: connect
    Received invalid ID string: Sorry, Could not connect to: linuxweb1.garibaldi.notts.sch.uk 22
    , (substr Sorr)

    Any help on this will be much appreciated

    Richard W

     
    • Graham Shedd

      Graham Shedd - 2006-10-17

      Richard

      did you manage to solve this at all, as I have exactly the same issue on solaris 10.

      Regards Graham

       
      • freeballer

        freeballer - 2007-01-23

        what happened to this thread? I've had same prob with ubuntu. did you get yours working?

         
    • Michael

      Michael - 2007-01-24

      I have found the nasty cause of the problem :-))
      I want it to share with you.
      Ubuntu and some other distributions of Linux use SSH2
      The Telnet/SSH login applet use version SSH.
      The option to set the applet to use SSH2 does not work (bug?)
      The solution is to use the SSH2 applet.
      This is almost a perfect copy of the Telnet/SSH login applet. Looks the same (almost)
      You can install it within Webmin using add modules by URL
      Add this URL
      http://www.webmin.com/download/modules/ssh2.wbm.gz
      Install it
      You can remove the Telnet/SSH login safely
      Have Fun

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks