SourceForge has been redesigned. Learn more.

Should Ubuntu users avoid Webmin?

  • Brandon Barnes

    Brandon Barnes - 2008-08-31

    I have used and enjoyed webmin for years, having great success on Suse boxes.

    Recently I've been setting up machines with Ubuntu Server and I had all kinds of trouble installing webmin, due to dependency problems. libnet-ssleay-perl is not in any standard repository for Ubuntu 7.10 or 8.04. I finally found a copy of that file and got webmin working.

    As I was asking for help in Ubuntu forums, I was told repeatedly not to run webmin with Ubuntu. Several people said it does not handle Ubuntu configurations well and causes problems. Is that true? It seemed to be the general consensus I heard, but I don't know what to make of it. I would hate to lose webmin by moving to another distro.

    Please say it ain't so!

    • Passh Reloaded

      Passh Reloaded - 2008-09-01

      It is really hard to believe what you are saying.

      The package "libnet-ssleay-perl" is called "libnet-ssleay-perl" on the standard Ubuntu repositories.
      Just check you are not trying to install OpenSuse instead of Ubuntu. :P

      Just type...
      prompt$ sudo apt-get update
      prompt$ sudo apt-get upgrade
      prompt$ sudo apt-get install libnet-ssleay-perl

      To install Webmin, type...
      prompt$ wget
      prompt$ tar -zxvf webmin-1.430.tar.gz
      prompt$ cd webmin
      prompt$ sudo ./ /usr/local/webmin

      When asked, change the webmin port to something else and use SSL if available on your server.
      That way you'll be running Webmin in 5 min.

      I have Webmin running on production servers without problem.

    • Brandon Barnes

      Brandon Barnes - 2008-09-01

      I have had this problem on repeated installs. It should be easy to duplicate.  Here's what I did:

      * Downloaded Ubuntu 7.10 server edition ISO.
      * Created a machine in VMWare server 1.0.6 with 384M of RAM and a 6G partition. I selected Linux / Ubuntu as the OS. Took everything else as defaults.
      * Mounted the ISO as the machine's CD-ROM and booted it. Installed with all the defaults. Since I just wanted to run squid, I did not select any of the server options, such as LAMP or Postfix, etc.
      * Ran apt-get update, apt-get upgrade, and then tried to apt-get install the list of files the webmin install page says are required. All of them worked perfectly except libnet-ssleay-perl. I get the following:

      Package libnet-ssleay-perl is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or is only available from another source
      E: Package libnet-ssleay-perl has no installation candidate.

      So this is the result of my apt-get install with the basic sources.list that comes with the distro. Right out of the box. After asking on several forums, I discovered that I had to add the following to my sources.list file:
      deb gutsy main restricted

      If I add that line, apt-get update, and then apt-get install libnet-ssleay-perl, it works fine. But I had to do a lot of searching and wade through several forums to get the answer. It definitely does not just install as easily as everything else because it's not in the default repositories. I even uncommented a bunch of them from the sources.list file, hoping to get lucky, but didn't. So I'm not sure how someone with a basic 7.10 install of Ubuntu Server is supposed to install webmin without a lot of detective work. Perhaps that repository is available for non-server versions of Ubuntu & Kubuntu, but it isn't for the server version. And I'm pretty I had the same outcome with 8.04, but I don't have the vm handy to check.

      It took hours of time to get it figured out. So when Ubuntu forum people told me that webmin really didn't support Ubuntu, and that's one reason the the ssleay package was so hard to find, I couldn't argue.

      But I am glad to hear you say that there should not be a problem with Ubuntu. I really rely on webmin and would hate to lose it just because I changed distros. Thanks for the assurance it works.

    • Brandon Barnes

      Brandon Barnes - 2008-09-01

      By the way, I just followed the exact same steps, but this time with Kubuntu Desktop 8.04. It worked with no problems. Perhaps the server version is more locked down and does not have as many repositories available by default for apt-get.

    • Passh Reloaded

      Passh Reloaded - 2008-09-01

      Well, I have never use Ubuntu 7.x.
      My distro was CentOS 5.0 but I unpluged me from that because is very old and difficult to compile > php 5.2.4.
      Then Ubuntu came to me and now I changed my name to Hardy.

      I really don't know if is possible to use webmin with Ubuntu 7.x. In Hardy is about 2 minutes install without problems!!!

      My recommendation is to avoid Kbuntu!!! Orange Ubuntu is like Apple and Kbuntu is like Windows.
      My first impression was that KDE have a better look than Gnome and it's true!
      However Kbuntu is a heavy and slow distro with useless stuff. At the end of the day I was installing Gnome over KDE and never back. All you need is Gnome and you can run all KDE applications from Gnome.

      Also, my Webmin feels happier on Ubuntu than Kbuntu.

    • Francewhoa

      Francewhoa - 2009-06-30

      Webmin is fully supported on Ubuntu 8.04:
      Works great for me.

      I wrote a how-to handbook at It covers installing Virtualmin, Webmin & Usermin on Ubuntu Server 8.04 LTS. It's for absolute beginners.

  • Jim (JR)

    Jim (JR) - 2011-03-27

    This REALLY annoys me.  I'm running 10.04 LTS server - which is strictly text mode - and I would like a SWAT-like web-admin portal for my box, since I don't want to bloat-ware my server with a ton of useless GUI stuff.

    I search on GUI replacements and I get this page ( ) where they are totally down on Webmin claiming that it will cause all kinds of doom-and-distruction - they recommend eBox, (which IMHO is a fuster-cluck from the word "GO!"),  or ISPConfig which appears to be bloat-ware ppar excellance unless you want to run a web-hosting service on your box. (!!!)

    I don't want something so complicated that I need to run out and buy half the LIbrary of Congress to figure out how to use it.  Web-min seems to be (in this case) the answer to a maiden's prayer.

    Of course, if you listen to them, they're all down on SWAT too, as they claim "it's not secure enough!"

    IMHO, anyone who is dumb enough to put a web-admin service out on the open Internet - regardless of port or secure session - deserves what they get.  My admin stuff is STRICLTY LOCAL, and the only way you can get to it is via a secure tunnel requirening vendor supplied software and a certificate exchange over a secure channel.

    Of course, they also are really down on logging in as root too.  And that I can understand - but there are times when I'm working on my server that being root has it's advantages.  If I had to sudo my way into everything I did, it'd take me two weeks to do five minutes worth of work! ( :grin: )

    This is what both confuses and upsets me with Ubuntu:
    They seem to be getting awfully "snooty" and too-big-for-their-britches.  Oooh!  Webmin isn't "geeky" enough!  We don't want our distro sullied by the common masses!!  (No kidding!  I have actually read complaints on some of the Ubuntu forums about how folks are objecting to the (ahem!) "dumbing down" of Ubuntu!)

    Go fiigure.

    What say ye?


  • zappepcs

    zappepcs - 2011-03-27

    I run Webmin on 8 Ubuntu systems, both server and desktop. Whatever problems others have had, I have not had. Webmin is the second thing I install on a new server… wrote scripts to make it easy. Oh, the first thing I install is Ubuntu. I would not hesitate to recommend the combination. If you have problems, this forum is quite useful.

    Ubuntu is honest about their intentions as a distribution. It, like any other distro, is a tool to run your apps. Do not think ANY distro is the answer to everthing. Webmin is not the answer to everything either, but the things it is not an answer to do not happen to very many people. The vast majority of us are quite happy with it on Ubuntu.

    I use no special configs, just load and go. I don't have heavy network admin or routing issues… just normal kind of stuff. I have no issues.

  • boldford

    boldford - 2011-03-27

    As a complete newbie I'm frustrated by getting Webmin working once, breaking it (I'm unsure how) and now cannot get it working again however hard I try.

  • Antoine

    Antoine - 2011-08-14


    I came across your post and am interested if you managed to find a solution. I am new to webmin and am playing around to set up a webserver on my home pc. Interested if you came right or if you are using another solution.


  • PhobosK

    PhobosK - 2011-08-30

    Just try removing the /etc/webmin folder out of its place (or delete it)…. This is a folder where old config options maybe stored and maybe they prevent you from running it?

    @ant01 what is the exact problem you have?

  • PhobosK

    PhobosK - 2011-08-30

    I do not see the reason you are annoyed with the guys from Ubuntu… I've seen such an attitude to Webmin on most distroes…
    Even worse attitude… like removing it from official repos because there is no distro developer capable of supporting distro specific install (this is Gentoo i am talking about… yes Gentoo - the geekiest distro out there) :D
    I guess the main reason is because Webmin is too powerful for an ordinary user, and it can mess up ANY system if the user doesn't exactly know what he is doing :D… Another reason is probably the fact that Webmin is too complex as a code to support, and setup/install… :)

    And this sudo thing is just a protection for the ordinary users in Ubuntu… no matter what they say…
    Ever since i use Ubuntu (a long time ago)… first thing i do is install my ssh cert in root's 'authorized_keys' so i get over this sudo when remoting (of course other security restrictions/tweaks apply too as a next step :) )…

  • tweaker

    tweaker - 2011-09-06

    I have installed webmin several times on 10.04 and now 11.04. I wouldn't be able to do it any other way, I have little linux experience.
    This guide has been invaluable.
    It is a mildly outdated, the dependencies have changed a little but it works every time for me and my home server.

  • tweaker

    tweaker - 2011-09-06

    Followup: After updating to 11.04, I now have the login problem others have in another thread. I will revert back to 10.10.

  • Goliath Technologies

    Ubuntu 12.04 LTS Server and Webmin works FINE, little tweaks to be made if you install dhcp and lusca servers, but that's all you'll have to do. I even recomend using Webmin on Production Servers where Security is an issue.


Log in to post a comment.