no upgrade link on System Information page

  • Robert Wooden

    Robert Wooden - 2014-03-27

    Webmin (on CentOS 6.5) is set to send me an email notificaion when system upgrades are available. I would simply login and there, on the 'System Information' page, would be a link to perform the upgrade. Since I upgraded to 1.680, I still get email notificatins but the link is missing on the 'System Information' page. How do I upgrade without that link appearing?

  • hansaplast

    hansaplast - 2014-03-27

    Interesting since I’m also on CentOS 6.5 and webmin v1.680 and I’m getting the link as usual. Could you try a reinstall?

    BTW: The link is available under System -> Software Package Updates

  • d elleray

    d elleray - 2014-03-27


    I have noticed some systems installed via an rpm (and therefore also get YUM notifications if the webmin repo is installed) behave differently re frontpage notifications to those installed via a tar.gz install.

    (likewise in the webmin upgrade page there are differences)

  • hansaplast

    hansaplast - 2014-03-27

    Since he's installing via Webmin, Robert probably uses package updates.
    Nevermind.. He could have installed Webmin via source of course...

    Last edit: hansaplast 2014-03-27
  • Robert Wooden

    Robert Wooden - 2014-03-28

    Well, my Webmin has no 'System -> Software Package Updates'. I do not remember if I installed from rpm or source but, this is my second version upgrade and the first one was to 1.670 (I think) and it upgraded fine. In other words I still had the upgrade link (with 1.670) when there were upgrades to be installed.

    I will add here that I have been searching throughout the various menus to see if there was another route to upgrades and updates. And I cannot find any.

    Any ideas what I should do, now? Perhaps a yum update??

  • hansaplast

    hansaplast - 2014-03-29

    First of all, check if the "software package update" module is installed. You can find installed modules under webmin configuration -> modules. If it is not installed, install it. Next you could you try is 'refresh modules'. Link is in the left pane near the bottom.
    If that doesn't work you can drop to the command line and type: yum reinstall webmin
    If that doesn't work you can upgrade your system without webmin and type: "yum upgrade" at the command prompt.

  • Robert Wooden

    Robert Wooden - 2014-03-30

    Thanks for your suggestions. I went into webmin configuration > (webmin) modules and could not find any reference to "software" or "software upgrades" or "updates". Because I could, I even searched through the 'deletable' drop down list to see if anything named "software" or "upgrades or updates" appeared as deletable. Nothing!

    When I ran "yum reinstall webmin" within the output was ". . Installed package webmin-1.680-1.noarch not available. Error: nothing to do." Hum-m-m . . .

    My memory of running the webmin update was because the information page indicated that a upgrade for webmin 1.670 was available. And yet yum is saying the above.

    I did run yum upgrade and let yum catchup with the various php programs that where waiting to be upgraded and that did not change anything on the system information page. Still no upgrade link.

    And finally I just re-started the box to see if that might make any difference . . . none.

    So, any other suggestions?

  • hansaplast

    hansaplast - 2014-03-30

    Ok. You've probably installed webmin via rpm. I find it easier to use the webmin yum repository. This way you're also able to update webmin via yum and all dependencies are installed automatically (well most of the time). Anyway. Please remove webmin:

    rpm -qa | grep -i webmin

    You should then find the exact package name. Then run:

    rpm -e <package name>

    to uninstall it. Then (re)install either with rpm or yum. I'd prefer the latter but that's up to you.

    The above suggestion will only work if you've installed the webmin rpm. If you've installed the source the above suggestion won't work and you should deinstall via source.

  • Robert Wooden

    Robert Wooden - 2014-03-31

    hansaplast thank you for your suggestions.

    Now that I have un-installed webmin when I "yum install webmin" I am being told by yum that "no package webmin available."

    I guess I need to fess up and tell everyone that this is a FreePBX Asterisk box telephone server. It was running on CentOS 6.5, key word here, 'was'. Recently, and I did not know this until yesterday, Schmooze, the company behind FreePBX, has begun re-branding CentOS to SchmoozeOS. Just a modified CentOS, I guess.

    So, as there is no webmin in the repositories connected to my OS (now SchmoozeOS) then I am taking the hint that, for now, we are not suppose to be using webmin for updates. I have asked this question over there on FreePBX forum and will keep others posted here.

    Last edit: Robert Wooden 2014-03-31
    • hansaplast

      hansaplast - 2014-03-31

      That could explain it.
      BTW: If you haven't added the "webmin yum repository" as pointed out in my previous post a "yum install webmin" is never going to work. If you don't want to install via yum or are not able to add the repository, you can also install the rpm directly using the folowing command in the CLI:

      rpm -U
  • Robert Wooden

    Robert Wooden - 2014-03-31

    One of the developers at FreePBX has just pointed out that they (Schmooze) has never included webmin in their repositories. Like I told them, I wish I had kept better notes about what and where I had gotten webmin. Apparently I added it from a downloaded rpm or something.

    Only because the box has such a singular job (telephone system) I am going to leave it as is with webmin un-installed. I am comfortable with using yum in the future.

    I learned a lot during these exchanges and I want everyone, especially hansplast, to know how much I appreciate your help and suggestions.

    I might use webmin in the future somewhere but, for now, with this box, no.

    Thanks everyone.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks