SourceForge has been redesigned. Learn more.
Close

Webmin on wildcard SSL

Webmin
Andrew
2013-09-19
2013-10-29
  • Andrew

    Andrew - 2013-09-19

    When I assign three files: crt, key and an intermediate chain file in the SSL configuration screen, it fails. Saying it could not write the pid file.
    The SSL cert works everywhere else with Vhosts.
    Webmin worked before trying to turn on SSL.

    Sometimes I have to uninstall Webmin and load it again to get it to fire back up - even after changing SSL=1 to SSL=0 in the miniserve conf.

    New to Webmin so any advice is good.

     
  • Andrew

    Andrew - 2013-09-19

    I ended up editing the conf directly and creating a new pem directly.
    For whatever reason, this worked while Webmin ssl config did not.

     
  • gandolf

    gandolf - 2013-10-29

    you need to provide the ssl data in the webmin configuration interface! webmin on install ill ask you http or https. WEBMIN DOES NOT RUN ON YOUR APACHE SERVER. webmin has its own httpd - that is why. and THAT IS A VERY GOOD THING.
    under no circumstances should you run webmin under your public web server.

     

Log in to post a comment.