Webmin with Apache 2.0.40 errors

Help
N Ward
2003-02-01
2013-05-22
  • N Ward

    N Ward - 2003-02-01

    I have been attempting for MONTHS to integrate webmin with apache.  I continually have two errors that appear in my error logs: 
    [Sat Feb 01 11:52:58 2003] [error] [client 192.168.3.1] Premature end of script headers: index.cgi, referer: http://www.norrcomm.org/
    [Sat Feb 01 11:52:58 2003] [error] [client 192.168.3.1] Can't do setuid, referer: http://www.norrcomm.org/

    I followed the instructions set out on http://www.webmin.com/apache.html and making the changes necessary for my system.

    I am running RedHat 8 kernel 2.4.19,and webmin 1.050.  I have perl 5.6.1 installed.  Here is my apache config for webmin:

    <VirtualHost 192.168.3.3:4000>
    DocumentRoot "/usr/libexec/webmin"
    ServerName webmin.norrcomm.org
    AddHandler cgi-script .cgi pl
    SetEnv WEBMIN_CONFIG "/etc/webmin"
    SetEnv WEBMIN_VAR "/etc/webmin"
    SetEnv SERVER_ROOT "/usr/libexec/webmin"
    SetEnv MINISERV_CONFIG "/etc/webmin/miniserv.conf"
    <Directory "/usr/libexec/webmin">
    Options ExecCGI
    #SetHandler cgi-script
    AuthName "Webmin"
    AuthType Basic
    require valid-user
    AuthUserFile /etc/webmin/htusers
    IndexOptions
    DirectoryIndex index.cgi
    XBitHack on
    </Directory>
    DirectoryIndex index.cgi
    IndexOptions
    XBitHack on
    </VirtualHost>

     
    • dkjkj

      dkjkj - 2007-01-18

      Did you get it resolved. I have the same issue using SLES 10 and apache 2.2.3

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks