File Manager corrupting files on edit?

Help
2009-08-05
2013-05-22
  • Jeremy Davis

    Jeremy Davis - 2009-08-05

    Hi,

    Server: Clean install of Ubuntu Server 8.04 (Hardy) running Webmin 1.480 (using this guide: http://www.ubuntugeek.com/ubuntu-serverinstall-gui-and-webmin-in-ubuntu-810-intrepid-ibex-guide.html\). Initially worked fine (accessed from XP SP3 desktop - Firefox 3.5.2 & Java 6.14).

    Using Webmin File Manager I edited my /etc/network/interfaces file (to set a static IP) I also renamed the original interfaces.orig. I saved, all good.
    I rebooted the server through webmin, and couldn't connect.
    When I logged into the server it had no network. I rebooted again and it errored on network connection. I checked the interfaces file and it is blank !?!? interfaces.orig is blank too!

    I edited the file locally. Rebooted, Webmin worked again.

    In Webmin I checked interfaces.orig and its all there! I opened interfaces again (using edit), selected 'save & close' (without changing anything). I also checked file permissions and couldn't see any problems.I restarted networking on the server and again no Webmin (or any networking at all). The File Manager seems to do something to the files that makes them unreadable to Ubuntu?

    Any ideas or have I missed something?

     
    • Jeremy Davis

      Jeremy Davis - 2009-08-05

      Oops, sorry for double post - I forgot to mention that its AMD64 Ubuntu.

      Also perhaps it is related to this https://sourceforge.net/forum/message.php?msg_id=7516113

       
      • Jeremy Davis

        Jeremy Davis - 2009-08-05

        I have enabled the root user in Ubuntu and logged into webmin using root (rather than my sudouser user account setup during install) and it seems to be working ok now?!

         

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks