Webmin on Windows won't open.

  • Anonymous

    Anonymous - 2010-08-04

    I just installed Webmin for Windows (WMW) on a local machine so I can administer my testing/development sites. I also installed ActivePerl Community Edition, which is required for WMW.

    When the WMW finished installing, it launched an internet explorer window with url http:localhost:10000/, which is what you'd expect. But the page can't be found. I've tried other browsers, changed http to https, and also tried, but none work.

    When requesting https (but not http) thru Chrome, I also get "Error 102 (net::ERR_CONNECTION_REFUSED): Unknown error."

    Neither Webmin nor Miniserv shows up as a service in the Windows services list. I tried a reboot, in case the service was in the startup folder, but no joy.

    I can't check the error log, because I don't know where it's located on a Windows install. A Windows search found no file called miniserv.error.

    I know of no firewall rules that might be affecting this, especially on a call to localhost, which should bypass the router & the modem entirely.

    Adding "Listen 10000" to httpd.conf does not work (nor should it, until I configure WMW to run under Apache).

    Thanks in advance,

  • Bill Mullen

    Bill Mullen - 2010-08-16

    I ran into that at one point in my winding road to installing Webmin to 2 different Win XP Pro SP3 machines.  I can't remember which issue caused that, but I came across a few useful pieces of info and a very useful page as well.  I documented most of my experience in the in the Webmin forum https://sourceforge.net/projects/webadmin/forums/forum/600155/topic/3811980.
    The thing that stands out most to me was that I found it necessary to make sure that the 2 folders you specify (or accept default values for exist.  The script didn't seem to want ti create them.  /etc and /var would normally already exist on any unix/linux/bsd flavor/dist.
    Also, if you are using the EXE installer, you will probably want to stick with Perl 5.8.8.  I think you can still download it from ActiveState.  However, if using the setup.pl from the latest Webmin version Perl 5.8.8 did not work for me.
    The other useful link is http://doxfer.webmin.com/Webmin/WindowsInstall.
    One thing it was missing was the download for OpenSSL.  It is possible to get a Windows binary which worked for me at http://www.slproweb.com/products/Win32OpenSSL.html.

    I know it's a lot of info..  Hope it helps.  I even got Cronw installed and working had to manually add the Perl modules in PPM though.

  • Bill Mullen

    Bill Mullen - 2010-08-16

    Almost forgot a very simple check that I used to confirm that the setup had in fact not completed correctly.  Check your running services in Control Panel or by typing "net start" in a command window.  You will likely not see webmin in the list.  After a successful install though it should be there at least if you chose to run on startup.

  • Anonymous

    Anonymous - 2010-08-16

    Thanks. The link to doxfer.webmin.com + your recommendations did it. Perl 5.8.8 is no longer hosted by ActiveState, but I found it here. (download starts immediately).

    Of note is the longer list of dependencies on the tutorial you pointed me too. I suspect some of the REQUIRED items aren't really (i.e., process.exe is nice, but you don't need it to run Webmin).


  • Bill Mullen

    Bill Mullen - 2010-08-17

    Glad to hear it worked.  I hadn't been sure about access to ActivePerl 5.8.8 because I had still had it downloaded from some time ago. 


Log in to post a comment.