Disk quota module error

  • samhill5215

    samhill5215 - 2011-03-25

    Not sure why I'm getting the following error when I try to set quotas:
    quotaon: cannot find /media/d2p1/quota.user on /dev/sdb1 

    Here's the details:
    OS: Ubuntu 10.10 server, two hard disks, second disk (/dev/sdb1) mounted on /media/d2p1
    Filesystem type: Linux Native Filesystem (ext3)

    Webmin reports User Quotas Inactive on this disk. Clicking the Enable Quotas link results in the error. I can set quotas manually but would like to do it through Webmin if possible.

  • samhill5215

    samhill5215 - 2011-03-25

    Some additional info on this subject:

    The file quota file actually exists on the target filesystem. However it is named 'aquota.user' (which is appropriate for the filesystem type) not 'quota.user' as reported in the error. I've manually renamed the file to the name reported in the error but the error still occurs. In fact the file is renamed back to 'aquota.user'.

  • samhill5215

    samhill5215 - 2011-03-27

    Here's my solution:

    Append the flag  -format=vfsv0 to all the commands used by webmin in the disk quota configuration module. Now everything works. The only problem with this approach is that the flag works only with newer linux filesystems. It would still fail if one were setting quotas on some other filesystem.

  • samhill5215

    samhill5215 - 2011-03-28

    Further update - problem solved, not sure how, not sure why. For other reasons I had to reinstall the server. After I installed webmin, followed by the filesystem where I wanted disk quotas and webmin's disk quota module everything worked without the -format flag. It's a mystery albeit a fortunate one.


Log in to post a comment.