Advice please on 'missing' webmin dependencies

Nick Chown
  • Nick Chown

    Nick Chown - 2014-01-02

    Hello, I apologise in advance for asking for advice on what most of you will no doubt regard as simple and obvious. My field is autism, not IT but I like to have some understanding of what people are doing for me hence I dabble in aspects of IT! I am developing an understanding of Ubuntu, webservers etc. with the objective of being able to set up and run Open Journal Systems journal hosting software myself, before handing the task to a hosting operation.

    I have an apache webserver running on Ubuntu in an Oracle VM VirtualBox virtual machine. My difficulty is in getting webmin to work. The problem appears to be 'missing' dependencies. I have scoured the internet for advice, read FAQs, tried everything I can think of, and spent too long on this already.

    If someone would kindly read through the following notes of my actions so far and tell me what I'm doing wrong it will be greatly appreciated.

    Thank you very much.


    Nick Chown

    Webmin installation notes - I mean "failed installation"!

    Install virtualbox
    Install Ubuntu 12.04
    Set up a new virtual machine running Ubuntu 12.04
    To install the Apache2 web server use the following commands:
    • sudo apt-get update
    • sudo apt-get install apache2

    Check that the web server works by putting the IP address ( in the web browser [N.B. just put in the address, no http:// etc]

    I should get the “It works!” default web page to show that the server is working but with no content as yet.

    The apache2 configuration files are kept in the /etc/apache2 folder. The main file is apache2.conf. To get a full list of the files in this folder use the following commands:
    • cd /etc/apache2
    • ls –F

    Then open up a file in the nano text editor the command is:
    • nano /apache2.conf

    [BE CAREFUL EDITING THESE KEY CONFIGURATION FILES!] [How to configure the Apache web server on Ubuntu & Debian]

    To install Webmin from the APT repository do the following:
    • sudo vi /etc/apt/sources.list (to edit this file in the vi text editor)
    • i (to change from command mode to insert mode)
    • Add the following lines to sources.list

    deb sarge contrib
    deb sarge contrib

    • Z (to close vi)

    Download GPG key using following commands:
    • wget
    • sudo apt-key add jcameron-key.asc

    Update source list with this command:
    • sudo apt-get update

    Install webmin with this command:
    • sudo apt-get install webmin

    Failed to install due to unmet dependencies:

    Ubuntu suggested running apt-get update but this did not work

    Then tried apt-get –f install and sudo apt-get –f install to no avail

    Checked Ubuntu forum at: for advice. I have already tried their suggestions and they do not work for me.

    Checked advice on installing webmin at:

    Checked latest version of webmin (1.660) and precise address of Ubuntu version [don’t forget the underscores either side of the version number]

    Install the webmin dependencies (I hope!!!) with the following command:
    • sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl

    This seems to have installed the missing dependencies except for libauthen-pam-perl! What next?
    The error message received is: “Package libauthen-pam-perl is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. E: Package ‘libauthen-pam-perl’ has no installation candidate.”

    Decided to ignore this for the time being and see if I can install the other dependency referred to by mametrockafella (libmd5-perl).

    One other dependency is libmd5-perl, but apparently is no longer available in the Ubuntu repositories so I need to use a workaround:

    • wget
    • sudo dpkg -i libmd5-perl_2.03-1_all.deb

    Unpack webmin with the following command:
    • sudo dpkg -i webmin_1.660_all.deb

    This produced the original list of missing dependencies which seems odd given that earlier it looked as if they had all been installed except for libauthen-pam-perl and libmd5-perl.

    Tried sudo apt-get install + the missing dependencies. This again appeared to reduce the list to libauthen-pam-perl and apt-show-versions as before as the others were not mentioned, although it doesn’t actually say that they have been installed (would it?).

    Again, the error message says that the missing dependencies “have no installation candidate”.
    Tried apt-get –f install which managed to install libnet-ssleay-perl but none of the other dependencies.

    Checked the webmin website which says that “If Debian complains about missing dependencies, you can install them with the command : apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions pythonIf you are installing on Ubuntu and the apt-get command reports that some of the packages cannot be found, edit /etc/apt/sources.list and make sure the lines ending with universe are not commented out.”

    Checked this file – none of the lines end with “universe”!!!!

  • VNS990

    VNS990 - 2014-02-27

    Wow and I thought CentOS was awkward.

    Ubuntu whilst great in the wilds of Africa I seriously do question it's abilities at times.

    I find it does for Linux what win8 does for windows.

    But in all seriousness for a beginner ouch that was a hard landing.

    Ubuntu whilst great on live cd's and dvd's and promoted by Nixie pixel and hoora hoopla.

    But I do tend to ask the question how many big gun corporate servers would be running Ubuntu or be even more cheeky and ask why?

    Not really a common platform it could be argued. Support next to nil on the server side of things great if your a gamer or a coder.

    The give away cd's and dvd's are handy in emergencies but otherwise only good for scaring birds from grapevines.

    CentOS, Red Hat server, and other variants are more common.

    And it could be argued easier debian Ubuntu and others are for those who know it will work or are more savy and can work around the quirks.

    Hopefully that's a bit more diplomatic than I was originally going to say :-)

    Goodluck though because Ubuntu it was just a sod to work with for me.

    No driver for this no codec or whatever for that go get this go do that bah learning centos was so much easier.

    Uh oh the natives have heard me I can hear the jungle drums now best be going Byee.

    Last edit: VNS990 2014-02-27

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks