#4239 Arch report service failure, however, iptables are applied/

1.630
open
5
2014-08-10
2013-05-18
M P
No

The issue https://sourceforge.net/tracker/index.php?func=detail&aid=3611901&group_id=17457&atid=117457
also exist in Webmin version 1.630.

webmin-iptables.service - Load IPtables save file
Loaded: loaded (/usr/lib/systemd/system/webmin-iptables.service; enabled)
Active: failed (Result: exit-code) since Sat 2013-05-18 13:40:19 EEST; 14min ago
Main PID: 138 (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/webmin-iptables.service

Discussion

  • M P

    M P - 2013-05-18

    webmin-iptables.service - Load IPtables save file
    Loaded: loaded (/usr/lib/systemd/system/webmin-iptables.service; enabled)
    Active: failed (Result: exit-code) since Sat 2013-05-18 14:03:05 EEST; 1s ago
    Process: 973 ExecStop=/usr/sbin/iptables -t mangle -P OUTPUT ACCEPT (code=exited, status=0/SUCCESS)
    Process: 970 ExecStop=/usr/sbin/iptables -t mangle -P PREROUTING ACCEPT (code=exited, status=0/SUCCESS)
    Process: 967 ExecStop=/usr/sbin/iptables -t nat -P OUTPUT ACCEPT (code=exited, status=0/SUCCESS)
    Process: 964 ExecStop=/usr/sbin/iptables -t nat -P POSTROUTING ACCEPT (code=exited, status=0/SUCCESS)
    Process: 960 ExecStop=/usr/sbin/iptables -t nat -P PREROUTING ACCEPT (code=exited, status=0/SUCCESS)
    Process: 958 ExecStop=/usr/sbin/iptables -t filter -P FORWARD ACCEPT (code=exited, status=0/SUCCESS)
    Process: 955 ExecStop=/usr/sbin/iptables -t filter -P OUTPUT ACCEPT (code=exited, status=0/SUCCESS)
    Process: 951 ExecStop=/usr/sbin/iptables -t filter -P INPUT ACCEPT (code=exited, status=0/SUCCESS)
    Process: 949 ExecStop=/usr/sbin/iptables -t mangle -F (code=exited, status=0/SUCCESS)
    Process: 945 ExecStop=/usr/sbin/iptables -t nat -F (code=exited, status=0/SUCCESS)
    Process: 943 ExecStop=/usr/sbin/iptables -t filter -F (code=exited, status=0/SUCCESS)
    Process: 940 ExecStart=/usr/sbin/iptables-restore </etc/webmin/firewall/iptables.save (code=exited, status=1/FAILURE)

    May 18 14:03:05 host systemd[1]: Starting Load IPtables save file...
    May 18 14:03:05 host systemd[1]: Started Load IPtables save file.
    May 18 14:03:05 host systemd[1]: webmin-iptables.service: main process exited, code=exited, status=1/FAILURE
    May 18 14:03:05 host systemd[1]: Unit webmin-iptables.service entered failed state.

     
  • M P

    M P - 2013-05-18
    • milestone: --> 1.630
     
  • M P

    M P - 2013-05-18

    From what i can see in journal:

    May 18 14:03:05 host systemd[1]: webmin-iptables.service: main process exited, code=exited, status=1/FAILURE
    May 18 14:03:05 host iptables-restore[139]: Can't open </etc/webmin/firewall/iptables.save: No such file or directory

    Of course, the file is there.

     
  • M P

    M P - 2013-05-18

    I've managed to fix it by removing the input symbol '<' from the line.
    However, I've noticed the following:

    It seems that after successful execution of webmin-iptables.service, ExecStop is called and its actions actions flushes all the iptables rules.

     
  • Jamie Cameron

    Jamie Cameron - 2013-05-19

    That's odd, Webmin 1.630 was supposed to fix this issue.

    Did you upgrade from 1.620, or was this a fresh install?

     
  • M P

    M P - 2013-05-20

    Both.

     
  • M P

    M P - 2013-06-30

    Please close the issue :):

    iptables.service - Packet Filtering Framework
    Loaded: loaded (/usr/lib/systemd/system/iptables.service; enabled)
    Active: active (exited) since Sun 2013-06-30 06:21:27 EEST; 11h ago
    Main PID: 1109 (code=exited, status=0/SUCCESS)
    CGroup: name=systemd:/system/iptables.service

    systemd[1]: Started Packet Filtering Framework.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks