#4101 Perl execution failed Server: MiniServ/1.580 - OpenVPN

1.580
closed-wont-fix
nobody
None
5
2017-03-01
2012-06-21
No

Whenever I go to the Key list under CA I get the following error:
HTTP/1.0 500 Perl execution failed Server: MiniServ/1.580 Date: Thu, 21 Jun 2012 08:03:42 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close

And if I go to VPN List and try to add a New VPN server I get the following error:
Error - Perl execution failed

Month '-1' out of range 0..11 at ./openvpn-lib.pl line 354

Now I was wondering whether this ia an error/bug for the Developer of the module or a webmin error. And how this can be fixed. I know have the issue that my OpenVPN server is unmanagable and I have some users that cannot login, but I cannot fix this without my panel.

Discussion

  • KorhalDragonir

    KorhalDragonir - 2012-06-21

    I forgot to mention I am running Ubuntu 12.04 amd64.

     
  • Jamie Cameron

    Jamie Cameron - 2012-06-21
    • status: open --> closed-wont-fix
     
  • Jamie Cameron

    Jamie Cameron - 2012-06-21

    It looks like a bug in the OpenVPN module, likely triggered by not handling month indexes properly (0=january, 11=december). I'd suggest contacting the author of that module if you can ..

     
  • Giuliano Natali

    Giuliano Natali - 2017-03-01

    This bug has been fixed in the OpenVPN module new version 3.0.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks