#2143 multiple webmin processes running

1.210
closed
None
9
2005-07-01
2005-07-01
homemachine
No

I have a lot of webmin miniserv procs running since
upgrading to 1.210. I have also upgraded the OS from
centos 3.4 to 3.5.
In the past there have only been 2 procs (sometimes 3)
running.
this is only happening on 1 machine and all were
upgraded at the same time.

2480 0.0 % Jun29 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
482 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
30369 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
2462 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
3596 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
4945 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
6682 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
14269 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
17023 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
21814 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
23263 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
24355 0.0 % Jun30 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
2449 0.0 % 00:03 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
6214 0.0 % 00:54 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
9526 0.0 % 01:40 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
9756 0.0 % 01:44 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
10604 0.0 % 01:58 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
16205 0.0 % 03:08 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf
24646 0.0 % 04:47 /usr/bin/perl
/usr/libexec/webmin/miniserv.pl /etc/webmin/miniserv.conf

another oddity, 2 other centos servers webmin is
running but won't allow access until I ssh in and restart.
The webmin server monitor also isn't sending mail to
say the process isn't running. (probably because it is
still running)

both are related and it's happening on other machines
too (rh9), various numbers of miniserv procs start up
and the old ones stay active too, 1 box has 30 odd
webmin procs running.
I'm not sure at what point yet but it appears all the
procs except one get killed which still allows webmin
to do it's stuff but I can't log in.

6 servers doing this

Discussion

  • homemachine

    homemachine - 2005-07-01

    Logged In: YES
    user_id=1116819

    last look on 1 server there were 51 procs now I can't log in...

     
  • homemachine

    homemachine - 2005-07-01
    • priority: 5 --> 9
     
  • homemachine

    homemachine - 2005-07-01

    Logged In: YES
    user_id=1116819

    upgrading to 1.216 has fixed it... man, thank you!

     
  • Jamie Cameron

    Jamie Cameron - 2005-07-01

    Logged In: YES
    user_id=129364

    This problem is most likely caused by an attack launched
    recently on NDMP servers, which also run on port 10000.
    Upgrading to development version 1.216 from
    http://www.webmin.com/devel.html should fix it..

     
  • Jamie Cameron

    Jamie Cameron - 2005-07-01
    • assigned_to: nobody --> jcameron
    • status: open --> closed
     

Log in to post a comment.