Help save net neutrality! Learn more.
Close

No Sound During Playback; Shortcut Keys Don't Work for Zoom (Ctrl +, Ctrl -, Ctrl0) on NumPad

Help
bejant
2014-03-11
2014-03-13
  • bejant

    bejant - 2014-03-11

    Hello,

    I've just started using WaveShop a few days ago. It's really handy and I like that it is lightweight and fast, but I've run into a few glitches.
    As the Subject of my post indicates, my biggest problem is when I Playback a .wav file with WaveShop I don't get any sound. I've tried changing Edit -> Options -> Audio Tab -> Playback Device from "Primary Sound Driver" to my sound card "SoundMAX Digital Audio" with no success. I also made sure that in WaveShop I don't have the sound muted, and the volume is all the way to the right.
    The .wav files are fine when opened in other apps (Windows Media Player, Audacity, QuickTime), and I have this problem with every .wav file.
    I tried with .mp3 files in the same session of WaveShop and the .mp3s play fine.

    A minor issue: The Zoom shortcut keys don't work for me on the Numpad either with NumLock on or off, but they do work when I use Ctrl +, -, etc. on the typewriter keys portion of the keyboard.

    I'm using WaveShop 1.0.14.1 on Windows XP. Thanks for any help!

     
  • bejant

    bejant - 2014-03-12

    I made a quick screencast that demonstrates the no sound and numpad zoom issues, to see it click here, and then maximize the window to fullscreen.

     
  • Chris Korda

    Chris Korda - 2014-03-12

    I would like to examine one of the problem WAV files. The best would be for you to post the file somewhere public that I can download it from. Otherwise you could zip it up and email it to me. I never post email addresses here, so if the latter is necessary, use the WaveShop contact page to send me a message, and then I'll have your email address and we'll take it from there.

    Also, what channel mask if any do the problem files have? You can see this via Audio/Speakers. I suggest experimenting with different channel mask settings.

    It's very possibly a driver-specific issue in which case I won't be able to replicate it.

     
  • bejant

    bejant - 2014-03-12

    Thanks for your reply. This happened with every file, so after reading your reply I had a look at looking at Audio -> Speakers. There I saw that none were checked, so turning on the speakers this way solved my problem.

    The last paragraph of the "Speakers" section of the WaveShop documentation says that if no speakers are assigned, a default assignment would be made.

    Maybe not for monaural (one channel) files?

    I really do like using WaveShop when I can because it is so fast when compared to something like Audacity.

    Thanks again for your help!

     
  • Chris Korda

    Chris Korda - 2014-03-12

    Mono files, interesting. And what speaker setting got it to work for you? I'm guessing you checked Front Left and Front Right.

    To answer your question, WaveShop's audio player replaces a zero channel mask with a reasonable default, for all channel counts, including mono. The relevant code snippet is enclosed below. As you can see, in the mono case, it sets the channel mask to Front Center, which works fine on every PC I've tested on. So it seems what we have here is driver-specific deviant behavior, which is typical of DirectSound and a real PITA.

    You might consider repeating this experiment on other PCs and I think the odds are excellent that they will behave better or at least differently.

    As keyboard accelerators (AKA shortcut keys) the numeric keypad keys are distinct from their non-keypad brethren, regardless of whether NumLock is on. This is stock Windows behavior and I'm not interested in fighting it.

    inline DWORD CDSPlayer::GetChannelMask(WORD Channels)
    {
        DWORD   mask;
        switch (Channels) {
        case 1: // mono
            mask = SPEAKER_FRONT_CENTER;
            break;
        case 2: // stereo
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT;
            break;
        case 3: // 2.1
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_LOW_FREQUENCY;
            break;
        case 4: // quad
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_BACK_LEFT | SPEAKER_BACK_RIGHT;
            break;
        case 5: // 4.1
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_LOW_FREQUENCY | SPEAKER_BACK_LEFT | SPEAKER_BACK_RIGHT;
            break;
        case 6: // 5.1
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_FRONT_CENTER | SPEAKER_LOW_FREQUENCY 
                | SPEAKER_BACK_LEFT | SPEAKER_BACK_RIGHT;
            break;
        case 7: // 6.1
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_FRONT_CENTER | SPEAKER_LOW_FREQUENCY 
                | SPEAKER_BACK_CENTER | SPEAKER_SIDE_LEFT | SPEAKER_SIDE_RIGHT;
            break;
        case 8: // 7.1
            mask = SPEAKER_FRONT_LEFT | SPEAKER_FRONT_RIGHT 
                | SPEAKER_FRONT_CENTER | SPEAKER_LOW_FREQUENCY 
                | SPEAKER_BACK_LEFT | SPEAKER_BACK_RIGHT 
                | SPEAKER_SIDE_LEFT | SPEAKER_SIDE_RIGHT;
            break;
        default:
            mask = (1 << Channels) - 1; // set one bit per channel
        }
        return(mask);
    }
    
     
    Last edit: Chris Korda 2014-03-12
  • bejant

    bejant - 2014-03-13

    For me any selecting any Left / Right pair works, but Front L/R and Side L/R work the best and equally well. I only have two speakers on this PC.

    The only two selections for which I get no sound are Front Center and understandably Low Frequency, but I just checked my Start -> Settings -> Control Panel -> Sounds and Audio Devices -> Volume Tab -> Speaker Settings -> Advanced and see Speaker Setup is set to 5.1 surround sound speakers.

    Thank you very much for your help!

     
  • Chris Korda

    Chris Korda - 2014-03-13

    Can you change your Speaker Setup to stereo? If you can, do so, and then see if you still need to specify a speaker mask in order to play WAV files.

     
  • bejant

    bejant - 2014-03-13

    I've corrected my speaker setup to "Desktop stereo speakers" but still need to specify a speaker mask in WaveShop in order to hear the file play. In other words, a speaker mask isn't automatically generated. The .wav file created in the screencast is here.

     
  • bejant

    bejant - 2014-03-13

    I forgot to mention now that I've changed my speaker settings to match my speakers, selecting any speaker mask produces sound when playing back the file.

     
  • Chris Korda

    Chris Korda - 2014-03-13

    Thank you for posting the file. It plays on my PC without specifying a speaker mask, indicating driver-specific issues. Please open one of the problem files, select "Front Center" ONLY in Audio/Speakers, and try playing it. I expect this to fail.

     
  • bejant

    bejant - 2014-03-13

    OK, now that I have my PC speaker settings set to "Desktop stereo speakers", the file plays:
    1. with no speaker mask selected,
    2. with ONLY "Front Center" mask selected as you mentioned in the previous reply,
    3. with any other speaker mask selected.

    I think the real issue might have been that this is a mono file and I erroneously had my PC speaker settings at "5.1 surround sound", but in reality am only two desktop stereo speakers?

    Or to put it another way, this was a PICNIC?

     
    Last edit: bejant 2014-03-13
  • Chris Korda

    Chris Korda - 2014-03-13

    I erroneously had my PC speaker settings at "5.1 surround sound"

    Don't know about picnic but for sure this was the real issue. Some audio drivers handle this situation better than others. Sounds like you're all set, enjoy!

    -ck

     
    Last edit: Chris Korda 2014-03-13

Log in to post a comment.