Linux server on new version of Linux?

  • thor101

    thor101 - 2007-01-10

    I tried to run the linux server, and it was demanding    I have .so.6 installed on my system, and it doesn't seem too happy with that.  I downloaded the source, but it didn't look like compiling just the server on linux was something easily done.  Any suggestions (other than reverting to so.5 to getting a server installed ?



    • James Coxon

      James Coxon - 2007-01-17

      Off the top of my head you could just make a symbolic link to .so.6

      Something like:

      ln -s /lib/ /lib/

      Someone correct me if i'm wrong...

    • thor101

      thor101 - 2007-01-18

      Ahh, I thought I put that in there, but I guess I forgot.  I tried doing a softlink, but Waste still didn't run correctly becaus it was looking for some function calls or something that it couldn't find.

      So yeah, I tried to softlink routine, but that didn't work.

      Since then, I actually got meshing to work so it is not as much of an issue.

      Thanks for the suggestion though.


  • johndoe32102002

    johndoe32102002 - 2009-12-08

    I got this error originally:
    ~/waste$ ./start
    ./wastesrv: error while loading shared libraries: cannot open shared object file: No such file or directory

    ln command:
    /usr/lib$ sudo ln -s /usr/lib/

    I got this error after trying the ln command:
    ~/waste$ ./start
    ./wastesrv: /usr/lib/ version "CXXABI_1.2' not found (required by ./wastesrv)
    ./wastesrv: /usr/lib/ version `GLIBCPP_3.2' not found (required by ./wastesrv)

    This probably means there are major differences in stdc++ v5 and v6 libraries.  Anyone have a fix for this to get the start (or wastesrv) script working?

  • Darck Clouds

    Darck Clouds - 2010-04-19

    anyone could help me out to able to make waste server works in  linux? i can't find the right version that works. what could be the solution?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks