Wapiti scan not running with Openvas scanner

  • shayno

    shayno - 2012-03-21

    I am attempting to integrate Wapiti into Openvas vulnerability scanner but have this issue:

    The Openvas scan report:

    "wapiti report filename is empty. that could mean that
    wrong version of wapiti is used or tmp dir is not accessible.
    Make sure to have wapiti 2.x as wapiti 1.x is not supported.
    In short: check installation of wapiti and OpenVAS"

    I created a small shellscript to run in $PATH:


    cd /usr/local/wapiti/src/
    ./wapiti.py $*

    I then did. chmod +x, to ensure wapiti.py was executable.

    chmod +x it, and ensure wapiti.py is also executable.

    I also added this line to the end of ~/.profile
    #run wapiti script

    Yet it still doesn't run when Openvas runs a scan.

    Any suggestions?

    • MrFlibble

      MrFlibble - 2014-11-18

      Hi Shayno,
      I have exactly the same problem, using the OpenVAS-7 DEMO 2.2 Virtual machine.
      When I run Wapiti from the command line, I get the following error:

      Traceback (most recent call last):
      File "/usr/bin/wapiti", line 37, in <module>
      from wapitiCore.language.language import Language
      ImportError: No module named wapitiCore.language.language

      This could be why we are getting the error in OpenVAS.

      Do I need change BASE_DIR in wapiti.py?
      I tried changing it to point to "/usr/lib/python2.7/site-packages" instead of "none", but that doesn't seem to have helped. I still get the error above.
      Unfortunately I know very little about Python :(


Log in to post a comment.