setup without static routes

Help
2008-10-03
2013-02-03
  • Todd Bradley

    Todd Bradley - 2008-10-03

    Is it possible to use WANem to set up a test environment where none of the devices under test have to have static routes configured?  Basically, I want to put a 2-NIC WANem PC inline in a network segment and have it pass packets through from eth0 to eth1 with certain impairments. 

    My test network is so complex that I can't reconfigure everything to have static routes to either end (eth0 or eth1) of the WANem box.

    Any suggestions?

    Thanks,
    Todd.

     
    • M K Nambiar

      M K Nambiar - 2009-01-19

      Hi Todd,

      Suggest you try the following

      Assume you have a 172.0.0.0/8 network on eth0 and 192.168.140.0/24 on eth1.

      One the WANem console do the following
      1>exit2shell
      2>route add -net 172.0.0.0 netmask 255.0.0.0 dev eth0
      3>route add -net 192.168.140.0 netmask 255.255.255.0 dev eth1
      4>wanem #To revert to the WANem shell

      Ideally this shd have been possible using the assign command in WANem.

      Regards,
      M.K.Nambiar

       
    • Juergen

      Juergen - 2009-05-05

      Hi all,

      I'd like to do an inline setup too.

      Client (192.168.0.10) -- eth0_WANem_eth1 -- Switch -- Router (192.168.0.1) -- RestOfTheWorld

      So I think I need:

      1) route add -net 192.168.0.10 netmask 255.255.255.255 dev eth0
      (Can I do that with assign too ?)

      2) Do I need a default route to eth1 (what is the syntax ?), or will that work out of the box ?

      3) I think, I need to CrossOver Cables for eth0 and eth1 ?

      4) And to get access to the WebGUI, I need an IP-Adresse (192.168.0.99) for eth0 or eth1, correct ?

      Any comments ?

      Thanks

      Juergen

       
    • M K Nambiar

      M K Nambiar - 2009-05-06

      1) Yes you shd do that with assign

      2) Shd work out of the box - just have the default gateway of eth1 as 192.168.0.1 when setting up the IP's.

      3) Not for eth1. For eth0 you might if both Client and WANem are really "old" boxes.

      4)yes.

      Regards,
      M.K.Nambiar

       
    • Juergen

      Juergen - 2009-05-09

      Just wanted to thank for the help and the great product.

      My feedback (maybe someone is interested):

      The minimum I had to configure was
      - to create a new (private) subnet to the client. So that WANem could act as a router.
      - And to add NAT.

      Client (192.168.80.10) -- (192.168.80.1) eth0_WANem_eth1 (DHCP + NAT) -- LAN-Switch -- Router -- RestOfTheWorld

      Client: 192.168.80.10 mask 255.255.255.0 Gateway 192.168.80.1 (DNS <My Normal DNS-Server)
      eth0: 192.168.80.1 255.255.255.0
      eth1: DHCP
      nat add eth1

      So if WANem could act as a DHCP server (on the eth0 side) it would be a bit easier.

      Many thanks again

      Juergen

       
  • Peter Tandler

    Peter Tandler - 2011-11-16

    Thanks for this description - this was exactly what I was looking for.

    I noticed that a DHCP-server is bundled on the Knoppix CD, so you can easily use this to provide DHCP for one or both subnets:

    Configure DHCP:

    pico /etc/dhcp3/dhcpd.conf
    

    as follows

    # no DHCP for the "external" subnet where NAT is enabled
    subnet 10.3.0.0 netmask 255.255.255.0 { }
    
     # DHCP for "internal" Client-LAN
     subnet 10.4.0.0 netmask 255.255.255.0 {
     range 10.4.0.10 10.4.0.250;
     option routers 10.4.0.1; ## IP of the WANem host
     }
    

    Start the DHCP server with

    /etc/init.d/dhcp3-server start
    

    This worked perfectly for me.

    Cheers,
    Peter

     

Log in to post a comment.