no more icon tray in ubuntu natty

Help
2011-04-18
2013-04-24
  • Le Gluon du Net

    Le Gluon du Net - 2011-04-18

    Hello,

    I have no wally icon in the gnome panel tray with Ubuntu Natty.
    I can reproduce this bug on 2 different computer with natty installed.

    Thanks for your help.

     
  • elle_r

    elle_r - 2011-04-29

    Same problem here on Natty.  I think Natty disabled all application system trays?  Not sure.  Wally works, but I can't customize it without the GUI.  Is there a way to access it via some cmdline parameters?  Thanks!

     
  • Antonio Di Monaco

    Hi,

    I hardly believe that, on Ubuntu Natty, system tray has been completely removed (maybe it has just been disabled by default, and you can enable it).

    Anyway, system tray icon support is provided by Qt, so it's out-of-scope from Wally's point of view. There are some shortcuts for control (README.shortcut file in sources), but they're active only for simple WMs, like FVWM. Global shortcuts for KDE/Gnome is not a portable concept.

    As soon as I can do it, I'll investigate for Natty system tray icon issue.

    BR,
    Tony.

     
  • elle_r

    elle_r - 2011-04-30

    Yeah, I figured something was up with Natty.  Got dconf-tools and added wally to the list of exceptions.  Thanks for the quick reply!

     
  • Le Gluon du Net

    Le Gluon du Net - 2011-05-05

    I'm not using Ubuntu app indicator but gnome standard systray icon. I added wally in the whitelist:

    gsettings set com.canonical.Unity.Panel systray-whitelist ""

    without success.

    Please help.

     
  • elle_r

    elle_r - 2011-05-08

    Still a bit glitchy.

    Loading of Wally icon in the panel in Natty doesn't happen all the time on startup; it's inconsistent.  I suspect that it loads before Compiz or w/e realizes that it needs to render the whole icon (if the icon isn't loaded, 1 pixel is loaded).

    Hopefully this will be fixed soon to make Wally compatible with the release of Natty!

     
  • Miquel Ràmia

    Miquel Ràmia - 2011-05-11

    Had the same issue: Wally systray icon disappeared in Natty. I'm not using Unity though, but 'classic' gnome2 desktop. Suddenly, today wally systray appeared again magically :P … gnome2 and compiz got really screwed with unity..don't like the way ubuntu is taking… tried Linux Mint and seriously thinking on using it permanently

     
  • Le Gluon du Net

    Le Gluon du Net - 2011-05-30

    I found a trick: when I kill the gnome-panel, it restarts with the wally icon (ubuntu natty).
    Is this bug is fixed in the last svn version of wally?

     
  • Antonio Di Monaco

    Hi,

    system tray icon management is not in Wally's scope. Refer to Ubuntu Natty bug tracking for further details.

     
  • Le Gluon du Net

    Le Gluon du Net - 2011-06-27

    It seems Ubuntu developpers finally solved this bug, I rebooted my computer several times on the past last days and wally icon is still in the gnome panel.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks