"not trained yet" message

Help
2011-04-16
2012-09-14
  • Nobody/Anonymous

    Why I get "not trained yet" message, and usage text to this command:

    waffles_learn train my.arff -labels 3 -ignore 0-2,4-5,24 bag 16 bucket
    decisiontree meanmarginstree end end

    ?

     
  • Mike Gashler

    Mike Gashler - 2011-04-16

    Short answer: This was a bug. I just fixed it.

    Long answer: When it tries to serialize the "bucket" object, it also needs to
    serialize all of the models in the bucket. By design, however, only the best
    model in the bucket for your problem is actually trained, so it failed when it
    tried to serialize the other models that had not been trained. In this case,
    "not trained yet" is the message reported by the decisiontree class when it is
    serialized, but has not been trained. This means that the "meanmarginstree"
    model must be getting better accuracy with your data. So, for now, a simple
    work-around is to use "bag 16 meanmarginstree end" as your model. It should
    obtain the same accuracy with your data since the decisiontree is apparently
    just dead weight. Another solution is to get the latest source code. (See htt
    p://waffles.sourceforge.net/tutorial/subversion.html)
    Thanks for catching this bug.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks