Problem solved.
I have renamed those 2 files:
vipl_x_gradient+section+vil1_rgb+uchar-.2-.section+vil1_rgb+uchar-.2-.vil1_rgb+uchar-.vil1_rgb+uchar--.cxx
vipl_filter_2d+section+vil1_rgb+uchar-.2-.section+vil1_rgb+uchar-.2-.vil1_rgb+uchar-.vil1_rgb+uchar--.cxx
in
vipl_x_gradient.cxx
vipl_filter_2d+section+vil1_rgb.cxx
and re-run Cmake.

Thanks to Peter Vanroose.

--
Gabriel Oheix



2008/3/12, gabriel oheix <gabriel.oheix@gmail.com>:
Hi,

I would like to try VXL, so I have download the vxl-1.10.0.zip file. I have used cmake to be able to compil/build with Microsoft Visual C++ 8 version 2005 (on Microsoft Windows XP Professionel version 2002 Service Pack 2).

While compiling the vipl library, it cannot reach the file:     vipl_x_gradient+section+vil1_rgb+uchar-.2-.section+vil1_rgb+uchar-.2-.vil1_rgb+uchar-.vil1_rgb+uchar--.cxx
I know that the file exist, I just wonder what is the building directory so I could follow the '../../../../contrib\tbl\vipl\vipl_with_section/...etc...' or '../../../../vxl-1.10.0/contrib\tbl\vipl\vipl_with_section/...etc...' (depending on where I have put my 'bin' directory).

According to the documentation, all my Visual C++ files are in a 'bin' directory. It should work like this:

 ---+--- vxl-1.10 ---+--------------- vxl
| |

| +--- vcl
| ...
|
+--- bin

My structure is more like that :
.../... ---+--- vxl-1.10.0 ---+------ vxl-1.10.0

|
+--- vcl
...

and I have tried to put the 'bin' directory to several place :


---+-----ROOT
|
|
+--- vxl-1.10.0 ---+------ vxl-1.10.0
| | |
| | +--- vcl
| | +--- bin

| | ...
| +--- bin
|
+--- bin

I don't think the name of this directory is really important, but as the path of the file
 is like '../../../../contrib\tbl\vipl\vipl_with_section/(and-so-on)', I thought it is just a problem of path.


I think it is just a stupid thing to do, but which one!


Thank you for reading.
--
Gabriel Oheix