Hi Mathieu,
 
Thanks for the comments.
As for the release number, you can see in file CHANGES.txt that 1.15 and 1.16 along with major changes in each are clearly documented. But for unknown reasons, there are no package files for there two releases. If you or other maintainers thought 1.15 would be better, I'll change the release number.
Comment 1: I'll rename vxl-1.17.0b.zip to vxl-1.17.0-b.zip
Comment 2: I see dcrispell have committed a patch today to fix the cycular dependency problem. This patch will be included in next release candidate.
Comment 3-5: I've successfully built the first 1.17 release candidate on both Windows and Linux (Cent OS 5)machine, so I am unware of these issues. I am also confused why there is a seperate VXL code base on Debian repository. Are these two code bases identical? If you think it necessary, please submit your patches to VXL repository at sourceforge.
 
Lianqing YU
2012-6-1
 
> From: mathieu.malaterre@gmail.com
> Date: Fri, 1 Jun 2012 16:02:34 +0200
> Subject: Re: [Vxl-maintainers] Introduce VXL 1.17.0 release candidate
> To: yulq@live.cn
> CC: vxl-maintainers@lists.sourceforge.net; vxl-users@lists.sourceforge.net
>
> BTW, why 1.17 ? The latest version was 1.14 right ?
>
> On Fri, Jun 1, 2012 at 3:59 PM, Mathieu Malaterre
> <mathieu.malaterre@gmail.com> wrote:
> > Hi,
> >
> > Some comments:
> >
> > 1. please keep the version numbering identical. We rely on robots to
> > read latest version. It is somewhat hard to explain that
> > vxl-1.17.0b.zip and vxl-1.17.0-b.tar.gz are idential (see extra '-').
> > 2. I cannot get vxl to compile:
> >
> > [...]
> > -- Configuring done
> > CMake Error: The inter-target dependency graph contains the following
> > strongly connected component (cycle):
> > "bwm" of type SHARED_LIBRARY
> > depends on "bwm_algo" (weak)
> > "bwm_algo" of type SHARED_LIBRARY
> > depends on "bwm" (weak)
> > At least one of these targets is not a STATIC_LIBRARY. Cyclic
> > dependencies are allowed only among static libraries.
> >
> > 3. SSE2 patch, this patch was pulled from itk at some point and AFAIK
> > required to build properly:
> > http://anonscm.debian.org/viewvc/debian-med/trunk/packages/vxl/branches/experimental/debian/patches/sse2.patch?view=markup
> >
> > 4. Very simple patch, this is a follow up to r31498
> > http://anonscm.debian.org/viewvc/debian-med/trunk/packages/vxl/branches/experimental/debian/patches/ffmpeg_C99.patch?view=markup
> >
> > 5. I believe someone already mentioned that before but there are some
> > issues with doxygen installation. I used:
> > http://anonscm.debian.org/viewvc/debian-med/trunk/packages/vxl/branches/experimental/debian/patches/install_doxygen.patch?view=markup
> >
> > Thanks
> >
> > On Thu, May 31, 2012 at 7:40 PM, YULianqing <yulq@live.cn> wrote:
> >> Hi all,
> >>
> >> I've uploaded the VXL 1.17.0 release candidate package to the sourceforge
> >> server for you to test. There are two files in the folder 1.17b. One is for
> >> Windows (vxl-1.17.0b.zip), and the other is for Unix
> >> (vxl-1.17.0-b.tar.gz). I am looking forward to your feedbacks.
> >>
> >> Best wishes
> >> Lianqing Yu
> >> 2012-6-1
> >>
> >> ------------------------------------------------------------------------------
> >> Live Security Virtual Conference
> >> Exclusive live event will cover all the ways today's security and
> >> threat landscape has changed and how IT managers can respond. Discussions
> >> will include endpoint security, mobile security and the latest in malware
> >> threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
> >> _______________________________________________
> >> Vxl-maintainers mailing list
> >> Vxl-maintainers@lists.sourceforge.net
> >> https://lists.sourceforge.net/lists/listinfo/vxl-maintainers
> >>
> >
> >
> >
> > --
> > Mathieu
>
>
>
> --
> Mathieu