A couple of months ago I sent the following message to the list:


  I had this problem some time ago. I do not remember the best solution, but I solved it by changing the following definition in CMakeCache.txt

//Flags used by the compiler during all build types.

I think some people proposed other solutions because this is not the best one, or there are other collateral problems... I am not sure. Anyway, it worked.


El 09/03/11 18:24, Phil Noonan escribió:
Hi again,

I added #include <stdint.h> and #define __SDTC_CONSTANT_MACROS to  /home/phil/vxl-1.14.0/core/vidl/vidl_ffmpeg_convert.h:21 but this did not seem to help. 

By editing /home/phil/vxl-1.14.0/core/vidl/CMakeLists.txt to include 

SET_SOURCE_FILES_PROPERTIES( vidl_ffmpeg_convert.cxx

Allowed vxl to compile up to 39%, but again it stopped due to a now familiar looking error message...

Linking CXX executable vnl_calc
[ 39%] Built target vnl_calc
Scanning dependencies of target vidl_test_all
[ 39%] Building CXX object core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_driver.o
[ 39%] Building CXX object core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_pixel_format.o
[ 39%] Building CXX object core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_pixel_iterator.o
[ 39%] Building CXX object core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_color.o
[ 39%] Building CXX object core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_convert.o
In file included from /usr/include/libavutil/avutil.h:81,
                 from /usr/include/libavcodec/avcodec.h:30,
                 from /home/phil/vxl-1.14.0/core/vidl/vidl_ffmpeg_convert.h:23,
                 from /home/phil/vxl-1.14.0/core/vidl/tests/test_convert.cxx:12:
/usr/include/libavutil/common.h: In function ‘int32_t av_clipl_int32(int64_t)’:
/usr/include/libavutil/common.h:157: error: ‘UINT64_C’ was not declared in this scope
make[2]: *** [core/vidl/tests/CMakeFiles/vidl_test_all.dir/test_convert.o] Error 1
make[1]: *** [core/vidl/tests/CMakeFiles/vidl_test_all.dir/all] Error 2

I tried to use a similar fix as for the previous error, i.e. by changing /home/phil/vxl-1.14.0/core/tests/CMakeLists.txt to include 


But this did not help. 

Any further tips?

Thanks again!

------------------------------------------------------------------------------ Colocation vs. Managed Hosting A question and answer guide to determining the best fit for your organization - today and in the future. http://p.sf.net/sfu/internap-sfd2d
_______________________________________________ Vxl-users mailing list Vxl-users@lists.sourceforge.net https://lists.sourceforge.net/lists/listinfo/vxl-users