It sounds like you do not need the authority index at all for your purposes. It might make sense to disable it by editing solr/solr.xml – that probably won’t solve the problem, but it may at least add confirmation (you should start getting 404 errors for posting to a non-existent index rather than 500 errors about a bad field).

 

I’m not sure why your import routine would be posting to the authority index, though – biblio should be the default unless you explicitly specify a different core. Could you share the exact command that you are using to index your records?

 

Thanks also for the translation help – I will send a separate email off-list with more details.

 

- Demian

 

From: Fang Peng [mailto:fang.peng@stonybrook.edu]
Sent: Monday, February 24, 2014 10:55 AM
To: Demian Katz
Cc: VuFind Tech Mailinglist
Subject: Re: vufind 2.2

 

Hi Demian,

 

It is what I felt strange. How can I make sure the data post to biblio? Here is the http://129.49.23.240:8080/solr. Suppose it should be posted to Biblio.

  • Start

2 days ago

  • Host

sbcourse

  • CWD

/usr/local/vufind2

  • Instance

/usr/local/vufind2/solr/biblio

  • Data

/usr/local/vufind2/solr/biblio

  • Index

/usr/local/vufind2/solr/biblio/index

 

My role changed and I don't do anything with library system anymore. But Vufind is great software and I love it. I am trying to use Harvest function to implement an University Class(Course) Search. 

 

For the Chinese Translation, I think I  still like to  help or  have my library friends to help before you can find any other to do so.  

On Mon, Feb 24, 2014 at 9:47 AM, Demian Katz <demian.katz@villanova.edu> wrote:

Based on the log file, it seems part of the problem is Solr doesn’t recognize the institution field. That’s part of the standard schema, so it seems strange that Solr is complaining about it. I notice that there’s a reference to the authority core right before the first error. Is it possible the data is somehow getting posted to authority instead of biblio?

 

On a completely different note, do you have time to work on an updated Chinese translation at some point? I didn’t hear back from you the last time I asked, but it appears that your email address has changed. If you are still able to help with that, let me know and I’ll send the missing lines. If you no longer have time, I understand!

 

thanks,

Demian

 

From: Fang Peng [mailto:fang.peng@stonybrook.edu]
Sent: Friday, February 21, 2014 5:56 PM
To: Demian Katz
Cc: VuFind Tech Mailinglist
Subject: vufind 2.2

 

 

I just installed vufind 2.2 in Linux (Ubuntu). 

 

Worked once, when i modified a  xsl  file in the  import directory and tried to reindex, then never get it to work. Even I put old xsl file back.  I can access following urls. 

 

 

 

 

 

 

When I started the vufind, following msg seems strange. 

 

"oejw.StandardDescriptorProcessor:NO JSP Support for /solr, did not find org.apache.jasper.servlet.JspServlet

Null identity service, trying login service: null"

 

when I ran the batch import for indexing and got error as following. 

 

2014-02-21T17:30:48-05:00 DEBUG: <= 400 Bad Request

Here is the log file. 

 

Any idea? 

Thanks

 

************

Fang Peng

Information Systems Access Control Manager /DoIT

Stony Brook University 

************************



 

--

************

Fang Peng

Information Systems Access Control Manager /DoIT

Stony Brook University 

************************