Based on the log file, it seems part of the problem is Solr doesn’t recognize the institution field. That’s part of the standard schema, so it seems strange that Solr is complaining about it. I notice that there’s a reference to the authority core right before the first error. Is it possible the data is somehow getting posted to authority instead of biblio?

 

On a completely different note, do you have time to work on an updated Chinese translation at some point? I didn’t hear back from you the last time I asked, but it appears that your email address has changed. If you are still able to help with that, let me know and I’ll send the missing lines. If you no longer have time, I understand!

 

thanks,

Demian

 

From: Fang Peng [mailto:fang.peng@stonybrook.edu]
Sent: Friday, February 21, 2014 5:56 PM
To: Demian Katz
Cc: VuFind Tech Mailinglist
Subject: vufind 2.2

 

 

I just installed vufind 2.2 in Linux (Ubuntu). 

 

Worked once, when i modified a  xsl  file in the  import directory and tried to reindex, then never get it to work. Even I put old xsl file back.  I can access following urls. 

 

http://129.49.23.240/vufind/Install/Home

 

http://129.49.23.240:8080/solr

 

http://129.49.23.240/vufind

 

 

 

When I started the vufind, following msg seems strange. 

 

"oejw.StandardDescriptorProcessor:NO JSP Support for /solr, did not find org.apache.jasper.servlet.JspServlet

Null identity service, trying login service: null"

 

when I ran the batch import for indexing and got error as following. 

 

2014-02-21T17:30:48-05:00 DEBUG: <= 400 Bad Request

Here is the log file. 

 

Any idea? 

Thanks

 

************

Fang Peng

Information Systems Access Control Manager /DoIT

Stony Brook University 

************************