I believe that the current trunk .jar files should work with version 1.3, though you may need to rebuild your browse indexes (and if you get any errors doing that, it may mean you need to add some missing files to the lib folder – I can’t remember if we changed to using ICU-based sorting between 1.3 and 1.4 or at some other time).


I believe that the problems you are seeing have to do with the searches generated by the AlphaBrowse code not having double quotes around them.  Looks like NLA is doing phrase searches but the current trunk code is not.  I’ll try to put in a fix for this in the next couple of days.  It’s probably just a matter of adjusting the template file for browse results.


- Demian


From: Spencer Lamm [mailto:slamm1@swarthmore.edu]
Sent: Tuesday, April 30, 2013 12:14 PM
To: vufind-tech@lists.sourceforge.net
Subject: [VuFind-Tech] Alphabrowse bugs?


Hi Everyone,

We've noticed two oddities with alphabrowse and I'm wondering if I need to upgrade our alphabrowse code as a first attempt to solve them. What is the latest alphabrowse code that is compatible with VuFind 1.3? Are these compatible?


And per this prior ticket it looks like I'll need to edit paths if I put new alphabrowse jar files in place? Is there's anything else I need to do? http://sourceforge.net/mailarchive/message.php?msg_id=29942478




1) The subject heading "World's Columbian Exposition (1893 : Chicago, Ill.)" runs a search against the index when clicked and that search fails. I've tried this in our catalog and Villanova's and found the same result. Click the first subject result on these pages to see this behavior.

Tripod: http://tripod.brynmawr.edu/find/AlphaBrowse/Results?source=topic&from=World%27s+Columbian+Exposition+%281893+%3A+Chicago%2C+Ill.%29



However, when I went to the National Library of Australia the same subject link works. http://catalogue.nla.gov.au/Browse/Subjects?browse=subjects&from=World%27s+Columbian+Exposition+%281893+%3A+Chicago%2C+Ill.%29


2) Running a subject browse on subject headings with a date range in the middle, like "World War, 1939-1945 Japanese Americans", leads to an incorrect result seemingly based only on the text up to the dash. The result in this case is "World War, 1939-1934 Concentration camps Songs and music ", which looks to be a match up to the dash only. Here is a link to the search in our catalog:

Unlike issue #1 above, I don't see this behavior in the Villanova or NLA installations of alphabrowse.


Spencer Lamm
Digital Initiatives Librarian
Swarthmore College Library