Ahh, sorry, I misunderstood.  Do you also have VUFIND_LOCAL_DIR set to the appropriate place?

Which version of 2.0 are you using?  If it's the 2.0beta release, I don't think the SolrMarc indexer that was bundled in had correct support for the 2.0 file structure.  You could update the SolrMarc.jar, VuFindIndex.jar and vufind.properties files from here and try again:


If you checked out a recent master branch from Git and have both environment variables set, it should be working...  but if it isn't, let me know and I'll investigate; I haven't tested on Windows lately, so perhaps there really is a bug!

- Demian

From: Lingley, Dean R [dlingley@purdue.edu]
Sent: Thursday, February 07, 2013 10:10 PM
To: Demian Katz
Cc: vufind-tech
Subject: Re: Vufind 2.0 minor indexing error on Windows

Hi Demian,
I have the home variable set to c:/vufind, but it's the web/conf/config portion which is no longer correct and that is the part that I' m assuming is hard coded somewhere in the track changes indexing code, because the error only occurred when I tried indexing with the two index lines uncommented in the marc_local.properties file.


Sent from my iPad

On Feb 7, 2013, at 8:05 PM, "Demian Katz" <demian.katz@villanova.edu> wrote:

The index tool reads the path to VuFind out of the %VUFIND_HOME% environment variable in Windows -- if you installed somewhere other than c:\vufind, you should be able to resolve this problem by setting the environment variable.  And, of course, the workaround you found with copying the files is another approach in a pinch!

- Demian

From: Lingley, Dean R [dlingley@purdue.edu]
Sent: Thursday, February 07, 2013 5:42 PM
To: vufind-tech
Subject: [VuFind-Tech] Vufind 2.0 minor indexing error on Windows

Downloaded the 2.0 and installed on a win 7 machine.  First indexing went great… things have really improved since I tried to install several years ago.


For the 2nd indexing attempt I enabled the:

first_indexed = custom, getFirstIndexed(001)

last_indexed = custom, getLastIndexed(001)


in the Marc_local.properties file.


On the next attempt to index I received an error:

Caused by: org.solrmarc.tools.SolrMarcIndexerException: Unable to access c:\vufind/web/conf/config.ini


So this path must be hard coded in those functions somewhere?  I just created the dirs and copied the config file for a quick fix, but I thought I would let someone know about the error too.