I assume that "web/config.ini" is just a typo -- but just in case it isn't, be sure you are editing "web/conf/config.ini" -- that's where VuFind looks for the configuration.  Assuming you are already editing the file in the correct location, are other changes to the configuration taking effect properly?  For example, if you turn on debug near the top of the file, do you see debug information when you do a search?

Regarding the template changes, have you tried clearing out your web/interface/cache and web/interface/compile directories?  Each of those two directories contains one or more subdirectories -- if you remove all of those subdirectories, you will be sure to eliminate any memory of past versions of templates.  Normally this shouldn't be necessary when you make changes (the timestamp change should automatically allow things to update), but maybe some limitation on your system is preventing this from working.

If clearing out cache and compile doesn't help, I would recommend double-checking all of your file paths and configurations to be sure you are editing the right file for the right theme.  Hopefully there is a simple explanation for this problem!

Please let me know if you still need help after trying some of these things.

- Demian

From: Haik Zargaryan [haikzargaryan@yahoo.com]
Sent: Friday, May 25, 2012 3:37 AM
To: vufind-general@lists.sourceforge.net
Subject: [VuFind-General] (no subject)

Dear community,

We are testing Vufind on our Ubuntu based server to deploy it as an OPAC for our library. Everything works fine. Yet, there is an issue that I am unable to solve. We want to modify some features, particularly how  records are displayed. We want to get rid of the Holdings tab. So, I have modified /web/config.ini to show by default the Description tab and then deleted the string below from /web/interface/themes/blueprint/Record/view.tpl file.

 <li{if $tab == 'Holdings' || $tab == 'Hold'} class="active"{/if}>
        <a href="{$url}/Record/{$id|escape:"url"}/Holdings#tabnav">{translate text='Holdings'}</a>
  </li>

Still, nothing is affected. What is more, Vufind does not react to any modification that I do. Even when i delete the whole code, it continues to work. Only when I do delete the file, it fails to display the record.

Moreover, this is a problem that I faced when dealing with other files as well. We do not need the Availability status of our records be displayed so I tried to delete the proper string from the file /web/interface/themes/[your theme]/RecordDrivers/Index/results.tpl. And again, no response. I had to eliminate that section through CSS (display:invisible). Restarting Vufind does not help either.

Any suggestion?

Thank in advance,
Haik.