Interesting, I am getting the same error importing authority records.  I have the VUFIND_LOCAL_DIR env var set.  The error affects 631 of 189958 records, so in this case it is clearly data dependent.  

Jonathan Rochkind reported seeing the error *erratically*, which is even worse: 
https://groups.google.com/forum/#!topic/solrmarc-tech/dzyysVDRubA
https://groups.google.com/forum/#!topic/solrmarc-tech/8Y77thTkmCo

From the error message, we suspect it is:

But let this be a lesson to the next error message you have to write: the most helpful form is "Require X, Got Y".  Then we would know for sure and wouldn't be talking about the same problem a whole year later!

--Joe



On Tue, Jun 3, 2014 at 11:37 AM, Anna Headley <anna3lc@gmail.com> wrote:
Yay I fixed it -- I hadn't set the VUFIND_LOCAL_DIR env variable.

Best,
Anna





On Tue, Jun 3, 2014 at 11:17 AM, Anna Headley <anna3lc@gmail.com> wrote:
Hi all,

I've been developing on a few different installs of vufind and I've had them all pointing at the same index. But now I need to point one at its own index. I've done this tons of times; I just give it a new port number and its own user, change a few config files and set the environment variables, and make a new init script for it. This time something weird is happening -- I try to index a file and a ton of the records give me this error:

ERROR [main] (MarcImporter.java:383) - ******** Halting indexing! ********
ERROR [main] (MarcImporter.java:380) - Unable to index record  (record count 36461) -- Value computed for Solr value "id" value must be a single String
java.lang.IllegalArgumentException: Value computed for Solr value "id" value must be a single String
        at org.solrmarc.index.SolrIndexer.getSolrId(SolrIndexer.java:1592)
        at org.solrmarc.index.SolrIndexer.map(SolrIndexer.java:811)
        at org.solrmarc.marc.MarcImporter.addToIndex(MarcImporter.java:399)
        at org.solrmarc.marc.MarcImporter.importRecords(MarcImporter.java:313)
        at org.solrmarc.marc.MarcImporter.handleAll(MarcImporter.java:607)
        at org.solrmarc.marc.MarcImporter.main(MarcImporter.java:867)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:622)
        at com.simontuffs.onejar.Boot.run(Boot.java:334)
        at com.simontuffs.onejar.Boot.main(Boot.java:170)

The same file indexes fine on the other instance. I have set them both to the same commit but same error.

I'm on vufind2, more or less current with master.

So I know it's not the records, and it can't be anything in the vufind codebase. Anyone have any idea where I can look to figure out this discrepancy?

Thanks,
Anna




------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/NeoTech
_______________________________________________
Vufind-tech mailing list
Vufind-tech@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/vufind-tech