Yay I fixed it -- I hadn't set the VUFIND_LOCAL_DIR env variable.


On Tue, Jun 3, 2014 at 11:17 AM, Anna Headley <anna3lc@gmail.com> wrote:
Hi all,

I've been developing on a few different installs of vufind and I've had them all pointing at the same index. But now I need to point one at its own index. I've done this tons of times; I just give it a new port number and its own user, change a few config files and set the environment variables, and make a new init script for it. This time something weird is happening -- I try to index a file and a ton of the records give me this error:

ERROR [main] (MarcImporter.java:383) - ******** Halting indexing! ********
ERROR [main] (MarcImporter.java:380) - Unable to index record  (record count 36461) -- Value computed for Solr value "id" value must be a single String
java.lang.IllegalArgumentException: Value computed for Solr value "id" value must be a single String
        at org.solrmarc.index.SolrIndexer.getSolrId(SolrIndexer.java:1592)
        at org.solrmarc.index.SolrIndexer.map(SolrIndexer.java:811)
        at org.solrmarc.marc.MarcImporter.addToIndex(MarcImporter.java:399)
        at org.solrmarc.marc.MarcImporter.importRecords(MarcImporter.java:313)
        at org.solrmarc.marc.MarcImporter.handleAll(MarcImporter.java:607)
        at org.solrmarc.marc.MarcImporter.main(MarcImporter.java:867)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:622)
        at com.simontuffs.onejar.Boot.run(Boot.java:334)
        at com.simontuffs.onejar.Boot.main(Boot.java:170)

The same file indexes fine on the other instance. I have set them both to the same commit but same error.

I'm on vufind2, more or less current with master.

So I know it's not the records, and it can't be anything in the vufind codebase. Anyone have any idea where I can look to figure out this discrepancy?