Sorry to hear you’re having trouble signing up for the mailing list – this is the first time I’ve heard of anyone having problems.  I have just added you to the vufind-tech list manually.  Please let me know if you continue to have problems!

 

Regarding your Voyager problem, this is also a new one to me – I’ve never before heard of only part of the driver working correctly.  Perhaps your particular instance of Voyager has a slightly different database structure than others.  Do you know what version you are running?  Do you have access to the Oracle database?  If you have database access, it might be worth testing the queries used by VuFind to see if you can track down where they are going wrong.  If you need tools to investigate further, let me know – I can share some code I have used when debugging my own institution’s Voyager system.

 

- Demian

 

From: Yanhong Wang [mailto:YWANG@shepherd.edu]
Sent: Wednesday, July 21, 2010 10:13 AM
To: vufind-tech@lists.sourceforge.net
Subject: [VuFind-Tech] Logging in to Voyager

 

This has been troubling me for quite some time. I couldn’t get authentication part to work.

 

I tried using ILS as authentication method, but getting an error message: invalid patron login. And then I switched to DB which was fine for adding to favorite, tagging and comment functions. But still I couldn’t connect to the Voyager database to get the patron information. Other part of Voyager driver seems working fine – live status and location information can be pulled from our Voyager database. Am I missing something?

 

And also, I tried to subscribe to the general mailing list from sourceforge several times, but never got the confirmation email. Is there any other way to do this?

 

Thanks in advance for any of your help.

 

Yanhong Wang