Regarding your protocol question -- when you respond to a message from this list, you can do a "Reply All" to ensure that your response goes both to the person you are replying to AND to the list itself.  This is usually the best option, since it ensures that the conversation is captured in the list archive where it can benefit others who have similar questions in the future.  However, you can also do a regular "Reply" to just the individual who sent the message if you wish to have a private, off-list conversation.


Regarding Solr not working after the reboot, this is normal -- unless you set up your system to automatically start VuFind on boot-up, it won't be running after a reboot.  You can start it back up manually:


cd /usr/local/vufind

./ restart


(Note that I used "restart" rather than "start" -- if you didn't manually stop VuFind before a reboot, it might think it is running even though it is not.  A "restart" will work correctly whether or not it was previously running, so it's the simplest option).


If you are interested in making VuFind start automatically, see this page:


(Note that this is a fairly recent addition to the documentation and not very detailed -- feel free to ask questions if you need more help).


Hopefully once Solr is running again, VuFind should get back to the point where you left off.  If you still get a generic "page not found" error, perhaps Apache is also not starting up automatically.  You can double-check that with:


sudo /etc/init.d/apache2 restart


If you can get back to the DB error you describe, it might help to copy the exact message here.  Based on your general description, I can think of a few possible explanations, but the most likely is that there is a problem with the connection string in config.ini.  Based on the file you sent, you have this:



database        = mysql://root@localhost/vufind


That will only work if you have a root user with a blank password, which you probably don't (at least, I believe the Ubuntu MySQL installation process encourages you to set a root password for the database).  Did you run through the /usr/local/vufind/install script as part of your setup process?  This is supposed to prompt you for a VuFind database username and password and then automatically update config.ini for you.  Perhaps you missed this step or something went wrong.  It might be worth re-running the install script to see if that fixes things.  If not, let me know and we can go through some additional troubleshooting steps.


As for your question about MARC designations, there are actually two pieces to this:


1.) There is a file called /usr/local/vufind/import/ which tells you which MARC fields get used in which of VuFind's internal indexes.  Although all the details of this file are not immediately clear, it should give you a fairly good idea of which fields are important.  You can find some documentation on this here:



2.) There are some places in the VuFind template files where MARC fields are read directly for display purposes.  Most of this happens in /usr/local/vufind/web/interface/themes/default/Record/view.tpl.  Don't worry too much if this code looks intimidating -- it's using most of the same fields as the file.  However, if you need to make changes to the way things are displayed, this is what you'll need to edit.


Hopefully this will help you move forward again -- let us know how things work out!


- Demian


From: Roland Mischke []
Sent: Tuesday, December 22, 2009 1:01 PM
Subject: Re: [VuFind-General] VuFind Install Problem


Thanks for the prompt replies to my post.


A question of protocol:  When I reply to a responder, do I send e-mails directly, or make a new post to the list?


Back to my problems.  Taking the advice of Till and Damien I have attached files for the config.ini and the Jetty output.  I may have made some stupid choices in the .ini file because I don't understand a lot of things, being neither a librarian nor a computer expert.


I rebooted the server before logging these files.  Under this reboot, I still get the message that solr is not running.


However, to muddy the waters a bit, before I had rebooted I had played around a bit and made some changes ( I don't recall what) and I got thru to the solr index.  The test files I uploaded are in there.  When I made a search in biblio, I got a message that there are no styles in the XML file.  I got a long XML listing with the information spread out and repeated in many formats.  This brings up the next question: how does VuFind interpret the MARC designations?  I know that other systems (like Evergreen) look for Dewey numbers in non-standard places.  Is there a listing somewhere that tells me to what MARC fields info should be mapped so VuFind can properly display it?


Under the the situation where I could access solr from a web browser, trying to get into VuFind via a browser gave an error message of DB not found or not connected (don't recall the exact wording).


When I rebooted the server, I could no longer get into solr, and got the standard page not found screen trying to access VuFind.


To respond to Till's question about the installation procedure, I did use the one he referenced.  Although, as I recall, that procedure didn't tell me I had to make executable in order to use it, because it came down with nobody having execute permission.


Time for some last minute shopping now.  Best wishes to all for this season, and always.


Roland Mischke