Hi.
>> What gave you the impression that configuration might be needed?  Maybe I’m missing something….
I think it must have been this post: http://bit.ly/5PQs5, but I looked in Smarty.class.php and Smarty_Compiler.class.php as you suggested and everything looked fine.

I had been running Smarty 2.6.25, upgrading to 2.6.26 has fixed the problem. Is 2.6.26 required (I tried a clean install of 2.6.25 but it still didn't work)? In any case, thanks!

Eoghan


On 21 January 2011 16:36, Demian Katz <demian.katz@villanova.edu> wrote:

Strange.  I’ve just merged my local Windows test instance with the latest trunk, and I’m not having any trouble…  of course, I’m using Windows 7 and stand-alone Apache rather than xampp, so it’s a significantly different environment.  However, I didn’t get the impression from anything I read that $smarty.get should ever be unavailable.  What gave you the impression that configuration might be needed?  Maybe I’m missing something….

 

Taking a quick look at the Smarty code shows that there is a property of the Smarty object called “request_use_auto_globals” which affects whether it uses the normal superglobals (true) or the old PHP4-style $GLOBALS array (false).  If that somehow got changed to false, I could see it causing problems…  but I can’t imagine why that would happen!  In any case, if you want to debug this, perhaps it would be helpful to look at the code in the _compile_smarty_ref() method of the Smarty library (found in Smarty/Smarty_Compiler.class.php wherever you installed the library).

 

Good luck, and let me know if I can be of further help!

 

- Demian

 

From: Eoghan Ó Carragáin [mailto:eoghan.ocarragain@gmail.com]
Sent: Friday, January 21, 2011 6:06 AM
To: vufind-tech@lists.sourceforge.net
Subject: [VuFind-Tech] Publication year facet & $smarty.get

 

Hi,
I've just merged my local copy of vufind with the trunk, but the date facet feature isn't working as expected.

It seems that my laptop (Win XP, xampp) isn't configured to use the {smarty.get} variable used in SideFacets.tpl. The various <input type="hidden" ...> elements that carry existing get parameters aren't generated, so when I apply a date facet it is like running a new search.

It seems from http://www.smarty.net/docsv2/en/language.variables.smarty.tpl that I may need to configure some other smarty/php variables for this to work. Any pointers?

Many thanks,
Eoghan