Hi Filipe,

Thanks for getting back to me so quickly! A few responses:


·         I have coverimages = Google,OpenLibrary in my config.ini


·         Could you please try this URL at VuFind install: <vufind root url>/bookcover.php?isn=0130461091&size=small. This works. I have over 80,000 records in VuFind - so far I haven’t found one cover image. I just plugged the ISBN for one of my records into this and was able to get a cover image (bookcover.php?isn=1901843130&size=small), but it’s not coming up in the results or in the record. When I look at image info for that record, it’s just vufind/bookcover.php (no isn or size). I see this in the apache access log: [30/Sep/2012:12:47:22 +0000] "GET /vufind/bookcover.php?isn=1901843130&size=small HTTP/1.1" 200 3435 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1".


·         I’m running this on EC2 so I don’t think a firewall is the problem, but I did wget a couple of things to make sure. That worked. The author info is also coming in from Wikipedia.


·         I just turned on debug but don’t see anything about bookcover.php


·         Looking at my apache error log from yesterday, I was getting the error below. Yesterday, I had config.ini set up to look for cover images at amazon, too. Now, I’ve just got Google and OpenLibrary and I’m not getting this error.


Thanks so much for your help!



In the apache error log from yesterday:


[Sat Sep 29 17:32:05 2012] [error] [client] PHP Parse error:  syntax error, unexpected '.' in /usr/local/vufind/web/bookcover.php on line 274, referer: http://my_vufind_instance.amazonaws.com/vufind/Search/Results?lookfor=music&type=AllFields&submit=Find




From: Filipe MS Bento (UA) [mailto:fsb@ua.pt]
Sent: Saturday, September 29, 2012 5:33 PM
To: Kathryn Frederick (Library)
Cc: vufind-general@lists.sourceforge.net; vufind-tech
Subject: Re: [VuFind-General] Cover Images


Hi, Kathryn!


Ok, lets start some troubleshooting.

So, it looks like you have done this step correctly from http://vufind.org/wiki/installation_ubuntu:


sudo chown www-data:www-data /usr/local/vufind/web/images/covers/*

and we can assume that in



you've activated at least one entry in [Content] related to cover images, for instance:


   coverimages = "Google,OpenLibrary"



Having this ok, for sure, two possibilities that seem really remote chances, but either way, I sending them because not seeing any other possible reasons for that to happen:

1) You are incredibly out of luck and *really* those books don't have cover previews in the services you've chosen;


For instances the one you sent, emulating an AJAX call to google books,




it returns an empty array (no data for that book found in google books), while, for instance,




returns a full array of JSON data (sending part of it)




          Could you please try this URL at VuFind install: 


<vufind root url>/bookcover.php?isn=0130461091&size=small 


(the book tested above)?

2) You are being firewalled (if so, I guess you would have noticed that for sure while doing any update or install [apt-get]): can your VuFind install display Author's Bio retrieved from Wikipedia (/Author/Home?author=Austen%2C+Jane%2C+1775-1817, for instance) --- if you have this feature active in web/conf/config.ini (authors = "Wikipedia", also in  [Content] section);


If so, you can try setup it up in [Proxy] section also web/conf/config.ini (like said, you should have that OK at the OS level, for instance, try a "wget http://www.google.com" (in /tmp or so) > should retrieve an index.html file;

3) (Extra and always the best way to troubleshoot VuFind) if not in production, or done at a low usage hour (4, 5am :) ):


activate debug = "1" ([System] section again in web/conf/config.ini and check for related errors (also you can try to catch a possible Apache's error with "tail -f  /var/log/apache2/error.log" -- if not in mistake, in Ubuntu it's the path to Apache error log).


I remember some messages about a related issue (and from a Google search), but it was in version 1.0, fixed in version 1.1, with Demian's patch http://vufind.org/jira/browse/VUFIND-320.


Was looking for more recent ones from the 179 messages "covers vufind" my e-mail retrieves and also from the Web, but not finding any directly related to this problem of yours... Sorry, but, if you followed all the steps in the wiki, as you did for sure, I see no other reason for that to happen. Perhaps, I am missing something very obvious... Demian, anyone?


I am carbon copying this message to vufind-tech so that we can continue the troubleshooting there (instead of vufind-general).


All the best  / have a nice weekend (hope I've helped somehow, someway),





On Sat, Sep 29, 2012 at 6:58 PM, Kathryn Frederick (Library) <kfrederi@skidmore.edu> wrote:


I’m new to VuFind and have a problem with display of cover images. “No Image Available” is displaying for all my records. None of the covers directories have images files in them, so I’ve been assuming this is a permissions issue. But the large, medium and small directories are all set to 777 and are owned by my apache user. I also tried changing the ownership of the covers directory to my apache user but that didn’t do anything. Some of the “No Image Available” covers are trying to link to an image, for example: bookcover.php?isn=0199896984&size=small. I have VuFind 1.3 installed on Ubuntu.


Thanks in advance for any suggestions!



How fast is your code?
3 out of 4 devs don\\\'t know how their code performs in production.
Find out how slow your code is with AppDynamics Lite.
VuFind-General mailing list